Announcement

Collapse
No announcement yet.

Security token missing when editing sections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Security token missing when editing sections

    Another problem. Problems everywhere

    When I try to edit a new section I get the error security token missing. Old sections have correct parameters and I want the new sections to have the same parameters, but that simply is not allowed for me. Too many problems with this CMS. Really unsatisfied.
    http://www.zazdravje.com.mk

  • #2
    Are you using customized templates?

    Are the articles really big?

    When did this start happening?

    Comment


    • #3
      Originally posted by Zachery View Post
      Are you using customized templates?

      Are the articles really big?

      When did this start happening?
      Hello Zachery,

      No, all the templates are reverted when I upgraded to 4.1.5. To some, I've made minor changes, but nothing special :S Though, I use modifications from vbulletin.org.

      Articles have around 5 000 to 10 000 characters maximum and from 1 to 10 images maximum.

      As I recall, this started happening from 4.0.7, but I didn't pay attention on this since I had no need to add new sections.
      http://www.zazdravje.com.mk

      Comment


      • #4
        Does it happen on shorter articles?

        Comment


        • #5
          Originally posted by Zachery View Post
          Does it happen on shorter articles?
          Maybe there is a misunderstanding here. Let's say I create a new section that belongs to the Front Page. That section has no articles. When I click edit on the section and check the pagination links radio button to Yes and click save, then I get the error about the security token. Also, when I hit edit on the section and change nothing, just click save, the error is happening again.
          http://www.zazdravje.com.mk

          Comment


          • #6
            Can you enable public phpinfo int the admincp and provide a link to your site? I'd like to check some settings.

            Comment


            • #7
              Originally posted by Zachery View Post
              Can you enable public phpinfo int the admincp and provide a link to your site? I'd like to check some settings.
              Sure, just to install English language and I will send you a pm with the login details.

              Thanks for helping me!
              http://www.zazdravje.com.mk

              Comment


              • #8
                Zachery, I've sent you a pm as asked 24 hours ago. Still no reply from you. Should I delete your admin account from my site?
                http://www.zazdravje.com.mk

                Comment


                • #9
                  This is a problem with your server, in particular the Suhosin module they may have added to PHP. Some things in vbulletin require higher limits than what suhosin has configured by default. If your host is not willing to do anything to fix this, then you MAY be able to override their limits by creating an .htaccess file with the following lines and placing it in your main forum directory:
                  php_value suhosin.request.max_vars 2048
                  php_value suhosin.post.max_vars 2048
                  Note: This will only work if your host has not blocked you from doing this.
                  If you are blocked from doing this by your host, then you will need to contact them for a resolution.

                  Comment


                  • #10
                    Thanks a lot!
                    http://www.zazdravje.com.mk

                    Comment


                    • #11
                      Originally posted by Zachery View Post
                      This is a problem with your server, in particular the Suhosin module they may have added to PHP. Some things in vbulletin require higher limits than what suhosin has configured by default. If your host is not willing to do anything to fix this, then you MAY be able to override their limits by creating an .htaccess file with the following lines and placing it in your main forum directory:
                      php_value suhosin.request.max_vars 2048
                      php_value suhosin.post.max_vars 2048
                      Note: This will only work if your host has not blocked you from doing this.
                      If you are blocked from doing this by your host, then you will need to contact them for a resolution.
                      Values are changed, still the problem remains Here is the public php info: http://www.zazdravje.com.mk/info.php
                      http://www.zazdravje.com.mk

                      Comment


                      • #12
                        I would advise checking the php/suhosin error logs or trying to disable suhosing temporarly to see if it is causing the problem

                        Comment


                        • #13
                          Originally posted by Zachery View Post
                          I would advise checking the php/suhosin error logs or trying to disable suhosing temporarly to see if it is causing the problem
                          Tried with suhosin disabled just for my site (shared hosting) but with no result. Suhosin is enabled for all the sites that are on the same server. I've asked the host to temporary disable suhosin for the whole server but that request was denied with explanation that it would require recompiling of the apache web server without suhosin and then recompiling again with suhosin which carries a risk for the other websites that are hosted on the same server.
                          http://www.zazdravje.com.mk

                          Comment


                          • #14
                            Zachery, anything new on this or should I file a support ticket?
                            http://www.zazdravje.com.mk

                            Comment


                            • #15
                              The issue is still with suhosin, they should be able to check their php/apache/suhosin logs and see what is triggering any of the rules and adjust them.

                              My big list of things to check
                              Code:
                              The following values may cause issues:
                              
                              suhosin.executor.disable_eval
                              If this feature is enabled, vBulletin will not operate.
                              
                              suhosin.memory_limit
                              If this setting is lower than the php memory limit, or is enabled, it will limit the total memory vBulletin can use, or operate with (such as for modifing images/upgrades/etc)
                              
                              suhosin.cookie.encrypt
                              This needs to be disabled for vbulletin to operate correctly
                              
                              The follwing 3 setting, if to low will not allow vbulletin to operate.
                              suhosin.post.max_vars => 2048
                              suhosin.get.max_vars => 2048
                              suhosin.request.max_vars => 2048
                              
                              suhosin.post.max_value_length
                              suhosin.request.max_value_length
                              default for these is 65000, this is the max amount of data that can be sent in a post. Users would be limited to 64500~ characters in a post.
                              
                              suhosin.get.max_value_length
                              This setting, if also to low may cause problems, default is 500.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X