Announcement

Collapse
No announcement yet.

MySql Upgraded to 5.1, Search not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • George L
    replied
    Yes if you upgraded mysql, best to recompile PHP as well

    Leave a comment:


  • docvader
    replied
    Thanks Eva, my issue has been resolved. I asked my web hosting company to look into the recently upgraded mysql and php because of this error, noting what you had mentioned. They apparently recompiled it, and it works now.

    Leave a comment:


  • George L
    replied
    Originally posted by docvader View Post
    I have the same problem, after upgrading mysql and php to the latest. running vbulletin 4.15 pl1. get Internal Server Error when I search on my forum (forum.russbo.com). my php.ini file does NOT have any Zend Guard stuff in it, just zend optimizer. (zend_extension="/usr/local/Zend/lib/Optimizer-3.3.9/php-5.2.x/ZendOptimizer.so").

    PHP 5.29. Mysql 5.1.56. Tables are all ok in vbulletin diagnostics. However, during phpmyadmin analysis, some of the tables, such as "cpsession" have a warning that says "the storage engine for the table doesn't support analyze". This occurred after the mysql upgrade. The "aggreggate temp" tables., and the bbm user and live tables say the same. During repair, the session table has a similar warning that says the storage engine for the table doesn't support repair. Other than that, the table status listings are all "ok". Repairing the tables has not helped.

    So much for zend guard. Any other ideas???
    session and cpsession tables are memory based and don't support mysql repair so that is normal. Just ignore cpsession and session reported messages when running mysql repair, check, analyse, optimise. You probably caught mysql server doing a mysql optimise, analyse, check, or repair which should so such status if you run such a task or have cronjob set to analyse, optimise and check/repair your databases. Could also be your server partitions or /tmp or mysql defined tmpdir in my.cnf don't have enough free disk space to accommodate your tablename_aggregate temp table where tablename is your database' table name that repair, analyse, check or optimise is attempting to run. You need at least 2-3x times the free disk space in /tmp or mysql defined tmpdir= in my.cnf as the largest mysql database table you run repair, analyse, check or optimise on. So if the table is 4GB in size, /tmp or mysql defined tmpdir= in my.cnf needs to have at least 12-16GB free disk space. Again if this is the case of lack of free disk space, you need to contact your web host

    As to internal server error that is a separate issue you need to look into with your web host. If you use whm/cpanel and recently recompiled apache or php via easyapache in WHM or via ssh2 telnet, it could be incorrectly configured apache/php config - which again you'd need to contact your web host. If don't use control panels but recently recompiled/reinstalled or upgrade apache or php, again it could be incorrectly configured apache/php configuration.

    You can start a new thread of your own and post info asked at http://www.vbulletin.com/go/tweak or use mysqlmymonlite.sh script to gather such

    Leave a comment:


  • Trevor Hannant
    replied
    Check your server's error logs - if you're getting an Internal Server Error then there should be a record of the error there.

    Please also start your own thread with full details seeing as you're having a different issue...

    Leave a comment:


  • docvader
    replied
    I have the same problem, after upgrading mysql and php to the latest. running vbulletin 4.15 pl1. get Internal Server Error when I search on my forum (forum.russbo.com). my php.ini file does NOT have any Zend Guard stuff in it, just zend optimizer. (zend_extension="/usr/local/Zend/lib/Optimizer-3.3.9/php-5.2.x/ZendOptimizer.so").

    PHP 5.29. Mysql 5.1.56. Tables are all ok in vbulletin diagnostics. However, during phpmyadmin analysis, some of the tables, such as "cpsession" have a warning that says "the storage engine for the table doesn't support analyze". This occurred after the mysql upgrade. The "aggreggate temp" tables., and the bbm user and live tables say the same. During repair, the session table has a similar warning that says the storage engine for the table doesn't support repair. Other than that, the table status listings are all "ok". Repairing the tables has not helped.

    So much for zend guard. Any other ideas???
    Last edited by docvader; Sun 21 Aug '11, 9:38pm.

    Leave a comment:


  • musclediscussion
    replied
    So i think it has something to do with zend guard.

    Leave a comment:


  • musclediscussion
    replied
    I downgraded the php version to 5.2.17 which automatically removed zend guard and installed only zend optimizer so my kayako which is encrypted script now works fine.
    Magically vbulletin also works fine with these settings.

    Leave a comment:


  • George L
    replied
    Downgrade of php or removing zend_guard fixed the problem ?

    Leave a comment:


  • musclediscussion
    replied
    It solved the problem. Everything is fine now.

    Thanks alot for you help.

    Leave a comment:


  • musclediscussion
    replied
    i have kayako support suite on another domain and that is not working as well. So i am downgrading php 5.3 to php 5.2 because i think that was upgraded as well. Than i'll try and fix this as well.

    Leave a comment:


  • George L
    replied
    to remove zend_guard, all you need is to comment out with semi-colon in front or remove 2 lines from php.ini

    Code:
    ;[Zend]
    ;zend_extension="/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so"

    Leave a comment:


  • musclediscussion
    replied
    I think during mysql upgrade easy apache ran and upgraded it as well. I am recompiling my php and apache now. I'll check it after and let you know.

    Leave a comment:


  • George L
    replied
    Did you recently upgrade apache or php as well ? I've seen this happen on some WHM/Cpanel servers when an easyapache recompile loaded zend_guard extension in php.ini. Removing it and restart apache fixed the problem.

    Leave a comment:


  • musclediscussion
    replied
    I have not changed any setting or anything of the script before and after upgrading mysql.

    Just tried rebuilt search indexes still not working. In google chrome it tells me this

    No data received

    Unable to load the web page because the server sent no data.
    Here are some suggestions:



    Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

    Leave a comment:


  • MySql Upgraded to 5.1, Search not working

    I just upgraded mysql to 5.1 and now search on my forum is not working. Everything was working fine before this and every other site on my server is working fine.

    Link: www.musclediscussion.com

    When i try to search something or getnewposts it shows a blank page.

    Need urgent help!

Related Topics

Collapse

Working...
X