Announcement

Collapse
No announcement yet.

Error Preview Topic

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error Preview Topic

    Hello,
    when previewing a discussion at the top the forum of the following error:


    Code:
    Warning: array_merge() [function.array.merge]: Argument #2 is not an array in [path]/includes/class_boostrap.php(414): eval()'d code on line 1143
    Warning: array_merge() [function.array.unique]: Argument #2 is not an array in [path]/includes/class_boostrap.php(414): eval()'d code on line 1143
    Warning: array_merge() [function.array.merge]: The argument should be an array in [path]/includes/class_boostrap.php(414): eval()'d code on line 1143
    Warning: array_merge() [function.implode]: Invalid arguments passed in [path]/includes/class_boostrap.php(414): eval()'d code on line 1143
    As Admin I can not reproduce the error, only the users experience the error

    What can it be?
    Italians Videogames Community

  • #2
    Eval() errors are from modifications.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X