Announcement

Collapse
No announcement yet.

Remove: Confirm that you want to leave the page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Remove: Confirm that you want to leave the page

    How do I stop this popup from showing? I never want it to show under any circumstances. Thank you.



    More info: It seems to happen whenever I create a new post then leave the page after its created. Also only started happening when CKEditor was implemented.
    vBulletin Rules!

  • #2
    You'd have to modify the software, there is no option to change it at thist ime.

    Comment


    • #3
      I'm fairly familiar with PHP. Do you think you could help me out?
      vBulletin Rules!

      Comment


      • #4
        You'd need to ask on www.vbulletin.org, which is the code modification site. Modifying the code isn't supported on here.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.0 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          This should not happen...

          Why has this not been resolved?
          www.yamaha-forum.net | www.exactservers.com | www.ducati-superbikes.com | www.suzuki-forums.net | www.diavel-forum.com

          Comment


          • #6
            Why has this not been resolved yet? Its a pita.

            Comment


            • #7
              They outsource their WYSIWYG editor so they don't have to deal with the problems anymore, I guess?
              vBulletin Rules!

              Comment


              • #8
                Check out http://tracker.vbulletin.com/browse/VBIV-12548 in there is how to disable this with a file edit.

                Comment


                • #9
                  Originally posted by MyDroidWorld View Post
                  Why has this not been resolved yet? Its a pita.
                  What is there to resolve?
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.6.0 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    Originally posted by Mark.B View Post
                    What is there to resolve?
                    This.



                    a lot of us dont want this, and liked the way the older editor functioned, without these messages.

                    Comment


                    • #11
                      Originally posted by The Rocketeer View Post
                      This.



                      a lot of us dont want this, and liked the way the older editor functioned, without these messages.
                      Exactly.... if it worked as intended it would be fine, but there are times when it pops up when posting and it shouldn't.

                      Anyway I have removed it via the tracker method on several sites already.
                      www.yamaha-forum.net | www.exactservers.com | www.ducati-superbikes.com | www.suzuki-forums.net | www.diavel-forum.com

                      Comment


                      • #12
                        Just do what Andy posted in Jira:


                        To disable this feature edit the clientscript/vbulletin_textedit.js file.
                        Find the following and comment out as shown:
                        Code:
                          //YAHOO.util.Event.addListener(window, "beforeunload", this.exit_prompt, this, true);

                        Comment


                        • #13
                          When I comment out that line I am unable to edit or delete posts in the forum. When I uncommented then it worked perfectly. This fix does not work?
                          vBulletin Rules!

                          Comment


                          • #14
                            Strange because i know that others use this to and they can still edit en delete posts.

                            Just Delete the following:
                            Code:
                            {YAHOO.util.Event.addListener(window,"beforeunload",this.exit_prompt,this,true)}
                            If you want the above solution to comment out the pop-up you need to download the uncompressed javascript files.

                            Comment


                            • #15
                              I think the problem was that I was using the compressed version of clientscript/vbulletin_textedit.js . Thanks.
                              vBulletin Rules!

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X