Announcement

Collapse
No announcement yet.

WYSIWYG Editor Missing (vB 4.1.4 Patch Level 1)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] WYSIWYG Editor Missing (vB 4.1.4 Patch Level 1)

    Greetings. I am experienced the bug described here. This is a brand new install with no plugins (aside from slimlinks). Posters in the aforementioned bug tracker thread suggested some modifications to clientscript/vbulletin_textedit.js. However, when I reviewed the file, I saw that the suggested changes were already implemented (presumably with a patch). Nevertheless, my WYSIWYG Editor buttons are still not showing.

    The forum is located here: http://www.stratics.com/forum. Thoughts?

  • #2
    Make sure all the WYSIWYG editors are enabled here:

    Admin CP -> Settings -> Options -> Message Posting Interface Options -> Enable Clickable Message Formatting Controls

    Then make sure you have selected the enhanced editor in your User CP:

    Settings -> Edit Options -> Message Editor Interface -> Enhanced Interface

    This should work assuming you have not altered the templates.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Yes, these were the first settings that I tried. All enabled. Still nothing. :<

      Comment


      • #4
        Then back to square one.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

        Admin CP -> Plugins & Products -> Manage Products -> Disable

        Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

        Admin CP -> Plugins & Products -> Plugin Manager

        You must do BOTH of those steps in order to disable all non vBulletin Modifications.

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Try : AdminCP -> Styles & Templates -> Style Manager -> Your Style -> StyleVars -> ImagePaths -> imgdir_editor
          Make sure the value is images/editor

          Comment


          • #6
            Originally posted by Steve Machol View Post
            Then back to square one.

            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

            Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

            Admin CP -> Plugins & Products -> Manage Products -> Disable

            Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

            Admin CP -> Plugins & Products -> Plugin Manager

            You must do BOTH of those steps in order to disable all non vBulletin Modifications.

            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

            Do you have the same problem?
            Tried all of these steps. Still nothing.

            Diagnostics shows:

            vbstopforumspam.php in ./archive


            --File not recognized as part of vBulletin


            functions_vbsfs.php in ./install/api


            --File not recognized as part of vBulletin


            install-original.php in ./install/includes


            --File not recognized as part of vBulletin
            However, I cannot find these files in the directories that they supposedly exist in.

            Comment


            • #7
              Originally posted by bpi007 View Post
              Try : AdminCP -> Styles & Templates -> Style Manager -> Your Style -> StyleVars -> ImagePaths -> imgdir_editor
              Make sure the value is images/editor
              Yep. Has the correct name.

              Comment


              • #8
                Can you provide a test account we can use?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Absolutely. What is the best way to send you the login credentials?

                  Comment


                  • #10
                    Since you do not have access to ticket support, post the test account here.Just a regular account, not an Admin.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Please use the following credentials:


                      Username: vb_test
                      Password: stratics.com
                      Address: http://www.stratics.com/forum

                      Comment


                      • #12
                        Best I can tell, this is either a server issue (possibly suhosin) or you did not enable the Enhanced Editor as per post #2.

                        Make sure all the WYSIWYG editors are enabled here:

                        Admin CP -> Settings -> Options -> Message Posting Interface Options -> Enable Clickable Message Formatting Controls

                        Also what do you have set for your forum URL here?

                        Admin CP -> Settings -> Options -> Site Name / URL / Contact Details -> Forum URL

                        What do you have set for here?

                        Admin CP -> Languages & Phrases -> Language Manager -> Edit Settings -> HTML Character Set

                        And finally, enable phpinfo in the Admin CP. This may help us troubleshoot this problem.

                        Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Forum URL


                          http://stratics.com/forum


                          HTML Character Set


                          ISO-8859-1


                          Public phpinfo


                          Enabled


                          Enable Clickable Message Formatting Controls


                          This image demonstrates that we have WYSIWYG enabled.





                          Server


                          This image demonstrates that the old WYSIWYG is working on a separate vBulletin install on the same server.


                          Comment


                          • #14
                            The most likely cause of this problem is the suhosin module in PHP. If so this can be fixed by editing the php.ini (requires root access to the server) or by via a .htaccess file with the following contents:

                            php_flag suhosin.cookie.encrypt Off
                            php_value suhosin.request.max_vars 2048
                            php_value suhosin.post.max_vars 2048

                            You can create your own .htaccess file and upload it to your main forum directory. It's a simple text file.

                            If this doesn't work or you get an 'Internal Server Error' after doing this, then unfortunately this means that your host is not allowing this change. The only thing you can do now is to ask your host to make the necessary changes to suhosin.

                            Here is a post that lists some of the recommended suhosin settings for compatibility with vB:

                            https://www.vbulletin.com/forum/show...82#post1329782
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              This is also happenings to my forums. It only started happening after I took the latest upgrade. I have done all the steps mentioned above, now I have disabled editor controls all together. I personally think this new editor has a bug because it worked fine before it came into play. If it helps, I am running on Private Servers hosted by DreamHost.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X