Announcement

Collapse
No announcement yet.

Friendly URLs and the unwanted /content/

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Friendly URLs and the unwanted /content/

    I forgot exactly why I never enabled Friendly URLs in one forum, right after I enabled I recall some of my advertisers complaining they were not able to verify if their links were actually in my home page.

    After all, my highest Page Rank is on my home page, but if it is tested with the domain.com/content/ it completely loses its value.

    With that in mind, I start searching in the forums and have seen a lot of messages asking for help into how to fix this little but very substantial issue. There are reports on the tracker, but not a convincing official answer.

    Now, it's quite peculiar, I have 2 forums, one on the root, another one inside a folder. The one inside the domain folder doesn't add the /content/ to the domain, I was wondering if my htaccess were any different, but no, they are the same, the one that vb adds on every package. And never added something special to any file.

    Now the root forum has exactly the same settings and adds /content/ on the home page.

    While searching for a fix to this, I found this thread with a plugin that must be applied into includes > init.php
    https://www.vbulletin.com/forum/show...ing-to-content

    Seems to do the job if you add the couple plugins described. But I know that eventually I will forget to apply the plugin on any upgrade.


    But an htaccess solution might be even better, so, I start searching and found nothing relevant.

    I'm not a coder, but thought this might help a little. So I added this to my htaccess:

    Code:
    RewriteCond %{HTTP_HOST}   ^[www\.]*domain.com/content/ [NC]
    RewriteCond %{REQUEST_URI} !^.*
    RewriteRule   ^(.*)  /$1  [L]
    I didn't edit the init.php file and it seems to be working.

    I'm using Mod Rewrite Friendly URLs, Canonical to Standard, Enforce to Yes, Unicode to UTF-8.

    Either way, would like to know if that rule I have is well written, and if it is, just to share it with those who have a similar problem.

    Thakns

    Note I don't publish content into the CMS, I use it as a homepage.
    Currently working on:
    Anizeen - What anime have you seen?
    Osito Barrigón - Winnie Pooh y sus Amigos

  • #2
    use the mod-rewrite friendly urls' but tell the software that the cms componet url is http://www.domain.com

    Comment


    • #3
      Have tried that, instead of content.php, tried it empty and index.php but nothing changed.
      Currently working on:
      Anizeen - What anime have you seen?
      Osito Barrigón - Winnie Pooh y sus Amigos

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X