Announcement

Collapse
No announcement yet.

Invalid Redirect URL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Invalid Redirect URL

    Hello,

    I'm hoping someone may be able to help.

    Members have reported a problem with logging in from the CMS home page. When they login they are shown an error message saying: I am using version (vBulletin 4.1.4 Patch Level 1)

    I have tested this with IE9 and the latest versions of Chrome and Opera and am seeing the same error message. Once you click on the back button or another link you are then shown as logged in. If you login via the forum page you will be logged in as normal. It only seems to be a problem with the CMS home page.

    This seems to only started happening since applying the vB 4.1.4 and vB 3.8.7 : Low Risk "phishing" patch.

    Has anyone else had this problem and can confirm please?


    Thanks for your help
    Dan

  • #2
    Someone told me about this today too, only seems to have started since yesterday when I installed 4.1.4 Patch Level 1, and the recent security fix on top of that (the files from the security patch were more recent so this seemed to be the correct order to apply the updates).

    edit - I've found the problem on my forum, it was related to the "Always use Forum URL as Base Path" option. This was enabled, which meant that when people accessed the forum without the www. they would get a redirect error when logging in, but with the www. was fine. Now the option is disabled, both URLs seem to be working OK again. This problem did only show up with the very latest round of updates though so the behaviour of this option seems to have changed recently.

    Comment


    • #3
      Thanks for your help.

      I tried this but it only seems to work with Firefox and Google Chrome. Internet Explorer and Opera will keep showing you as not logged in and no amount of re-logins will get you in. Like you say, this has only started happening since the security fix.

      Comment


      • #4
        http://www.foggyfriends.org/forum/forum.php they are not using the www this is why they are getting that

        Comment


        • #5
          Thank you for your help.

          I have just checked Site Name / URL / Contact Details - URL of your forum. Note: do not add a trailing slash. ('/') and this is set to http://www.foggyfriends.org/forum so I cannot understand how I am not using the www.

          I haven't changed any settings and this has only started happening since the phishing patch.

          Comment


          • #6
            I am having this problem on Vbulletin 3.8 as well but I can't use the Base URL fix since it doesn't exist in Vbulletin 3

            Comment


            • #7
              Originally posted by canyoncomposite View Post
              I am having this problem on Vbulletin 3.8 as well but I can't use the Base URL fix since it doesn't exist in Vbulletin 3
              This is probably a cookie domain/path issue. To fix this, upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Use this to reset the cookie domain and path back to the defaults. And then leave your cookie domain and path at the default settings. There is no reason to change these. If you need to specify aunique cookie, use the cookie prefix setting in config.php instead.

              Comment


              • #8
                No it isn't as no settings are changed and only the security patch is applyed. So the problem is caused by the security fix.
                Greetings, Black Tiger

                Comment


                • #9
                  Originally posted by cdr740 View Post
                  Thank you for your help.

                  I have just checked Site Name / URL / Contact Details - URL of your forum. Note: do not add a trailing slash. ('/') and this is set to http://www.foggyfriends.org/forum so I cannot understand how I am not using the www.

                  I haven't changed any settings and this has only started happening since the phishing patch.
                  you need to change the link in your brower as you are still using the old one

                  Comment


                  • #10
                    I tried that and it's still a no go. It's something to do with the latest VB patch. I shouldn't have to be asking members to use a different URL or messing around with settings that always used to work. This is a bug that has been introduced since the latest security patch.

                    Comment


                    • #11
                      It's ok...It's fixed now.

                      I just needed to add the domain name without the www to the whitelist.

                      Comment


                      • #12
                        I'm having the same problems since installing the patch. None of the suggestions here have resolved it - is it then a case of waiting for a fix to be produced?

                        Thanks

                        Comment


                        • #13
                          If you're using the www version of your domain in the Forum URL field, have you added the non-www version to the whitelist? Or vice-versa?
                          Vote for:

                          - *Admin Settable Paid Subscription Reminder Timeframe*
                          -
                          *PM - Add ability to reply to originator only*
                          - Add Admin ability to auto-subscribe users to specific channel(s)
                          - "Quick Route" Interface...

                          Comment


                          • #14
                            Originally posted by Trevor Hannant View Post
                            If you're using the www version of your domain in the Forum URL field, have you added the non-www version to the whitelist? Or vice-versa?
                            I have never had anything in the whitelist before - this is what I have:

                            Forum URL
                            URL of your forum.
                            Note: do not add a trailing slash. ('/')
                            http://rwf-forum.co.uk/vBulletin

                            Homepage URL
                            URL of your home page.
                            http://rwf-forum.co.uk/vBulletin

                            Thanks

                            Comment


                            • #15
                              Trevor,

                              Having entered into the whitelist the www version of our domain, all appears to be working properly again.

                              Many thanks

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X