Announcement

Collapse
No announcement yet.

CMS as root

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loco.M
    replied
    Originally posted by crazyfruitbat View Post
    Why so aggressive dude? It actually states in the guide to do this:
    Trust me, that wasn't aggressive in the least

    Leave a comment:


  • traen
    replied
    To set cms as root, this is all I did.

    Login to admin control panel>Settings>Options>Content Management>Site Tab URL>Set to "./" without the quotations. Click save.

    Done.

    Edit to add: I also have Point CMS default to index.php set to no if that helps.

    Leave a comment:


  • crazyfruitbat
    replied
    Originally posted by Loco.M View Post
    why are you uploading anything in a folder that says "do not upload" ?
    The error says you don't have an index.php file in your root or a content.php file

    fix that first
    Why so aggressive dude? It actually states in the guide to do this:

    CMS Component URL
    Optional URL for your CMS.

    If this is specified it will override the Forum URL setting for CMS pages. You may specify an absolute URL or a URL relative to your Forum URL

    Examples:
    http://www.example.com
    http://www.example.com/cms
    cms

    The URL should not have a trailing slash or contain the special directories ../ or ./

    Note: If you change the CMS URL you must upload the CMS stub directory. See help for further information.
    This feature requires that the "Always use Forum URL as Base Path" be set to yes.
    This will override the main Forum URL setting for CMS pages to allow the CMS pages to be accessed from a different directory than the rest of vBulletin. This value can either be an absolute URL in which case it fully overrides the Forum URL or it can be a relative URL, in which case it is appended to Forum URL.

    For example, if vBulletin is located at http://example.com/vbulletin then entering a value of "cms" will result in the CMS being located at http://example.com/vbulletin/cms. A value of "http://www.example.com/cms" will result in the CMS being located at http://www.example.com/cms. All vBulletin URLs must have the same host name.
    In addition to setting the CMS Component URL, you will need to take the following steps in order for the CMS to work in the new location.
    1. If you are locating the CMS in a directory other than a direct subdirectory of the vBulletin directory (http://example.com/vbulletin/cms in the above example), then edit cms/vb_dir.php in the do_not_upload directory of your download package to set the vBulletin install directory. Instructions are given in that file.
    2. Upload the CMS files directory from the do_not_upload directory to the directory you want the CMS to be located in. If you want the CMS to be in http://example.com/vbulletin/mycms, create a subdirectory in your vBulletin directory called mycms and upload the CMS files there.
    3. If you are using rewrite friendly URLs, you will need to copy the .htaccess file from do_not_upload/rewrite/apache2/cms to the stub directory before uploading. If the cookie path option is set for the site, it needs to be general enough to include all vBulletin URLs. For example, if vBulletin is located at www.host.com/mysite/vbulletin but the cms is located at www.mysite.com/mysite/cms then a cookie path of "mysite" will work, but a cookie path of "mysite/vbulletin" will not work because the cookies will not be sent to pages in the mysite/cms directory.
    Originally posted by gakz View Post
    ^ What he said.. you need to have an index.php file loaded onto your homepage/server that loads CMS...

    My index.php has:
    I have both the content.php and index.php inside /. The index file is exactly the same as yours.

    OK lets start from scratch maybe I missed something - if you want the CMS to show on your homepage, how did you do it? Certainly VB are doing it differently than when VB4 was just released (which everyone used a hack to get around it)

    Leave a comment:


  • gakz
    replied
    ^ What he said.. you need to have an index.php file loaded onto your homepage/server that loads CMS...

    My index.php has:

    <?php
    define(VB_RELATIVE_PATH, 'forum');
    chdir('./' . VB_RELATIVE_PATH);
    require('content.php');

    Leave a comment:


  • Loco.M
    replied
    why are you uploading anything in a folder that says "do not upload" ?
    The error says you don't have an index.php file in your root or a content.php file

    fix that first

    Leave a comment:


  • crazyfruitbat
    replied
    anyone guys?

    Leave a comment:


  • crazyfruitbat
    started a topic [CMS] CMS as root

    CMS as root

    Ok. I'm having issues with putting the CMS as the site's homepage

    Site Name / URL / Contact Details is set to CMS Component URL:http://www.nerdjackers.com
    I have uploaded the
    contents of the CMS folder in the Do not upload files and I get this as an error
    Warning: require_once(/home2/nerdjack/content.php) [function.require-once]: failed to open stream: No such file or directory in /home2/nerdjack/public_html/index.php on line 4

    Fatal error: require_once() [function.require]: Failed opening required '/home2/nerdjack/content.php' (include_path='.:/usr/lib64/php:/usr/lib/php') in /home2/nerdjack/public_html/index.php on line 4


    any ideas?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X