No announcement yet.

lots of database errors since upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] lots of database errors since upgrade

    I recently upgraded to 4.1.4 and now I'm seeing a big spike in the number of database errors I'm getting on the site. Before the upgrade I would get a few each day, mostly of the "too many connection" type, which is odd because I hardly ever have more than 30 users on at once.

    anyway I was just replying to a post and had a database error again. There is only 28 users on right now, 4 members, 24 guests.

    This time most of the messages say that it couldn't connect to the database, which I guess means that mysql went down? There are also a ton of emails with "Invalid SQL statements"

    I'm not sure what I can post to help sort this out. I've got about 75 error emails from just this one incident. Would posting a sample of the emails help?

  • #2
    1. Assuming the db info in your config.php file is correct, this is a server issue. Please see this page for the causes of this error:

    2. Invalid SQL errors are almost always related to modified code.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    • #3
      This maybe the "innodb" problem, as every one of the emails has the "Unknown table engine 'InnoDB' error in it. How/ why would that have changed with the upgrade?


      • #4
        over 300 error emails since this morning... and everyone one of them has the innodb error. Here's a sample.

        Invalid SQL:
                                 SELECT searchlogid, dateline
                                 FROM searchlog AS searchlog
                                 WHERE ipaddress =''
                                 ORDER BY dateline DESC LIMIT 1;
         MySQL Error   : Unknown table engine 'InnoDB'
        Error Number  : 1286
        Request Date  : Thursday, June 23rd 2011 @ 12:53:25 PM
        Error Date    : Thursday, June 23rd 2011 @ 12:53:25 PM
        Script        : [URL][/URL]
        Referrer      :  
        IP Address    : 
        Username      : Unregistered 
        Classname     : vB_Database 
        MySQL Version :


        • #5
          when I do the suspect file versions, I get a lot of "File not recognized as part of vBulletin" which look to be mostly old files from previous versions and some other system files I have in there.

          But there are two files that are marked as "File does not contain expected contents"

          they are "./clientscript/libraries DD_belatedPNG_0.0.8a.js" and "./clientscript/yui/history/assets blank.html"

          I tried ftp'ing them directly from the zip file, but they still give the same error.


          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.