Announcement

Collapse
No announcement yet.

I hate ckeditor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by worried View Post
    How is that possible especially when vB says otherwise?

    http://tracker.vbulletin.com/browse/VBIV-12092

    Myself and my members cannot post from the iphone. Other members can't post from their ipad. Did you install a patch?
    I didn't install the patch.

    Please don't assume that the problem is true for everyone. If that were the case you would see a lot more confirmations in the JIRA report. Based on the few JIRA comments, my hunch is the problem only effects a few users.

    Comment


    • #32
      It is not causing issues for all users, we were not able to reproduce the bug locally before going live with the launch AFAIK.

      Comment


      • #33
        Originally posted by worried View Post
        How is that possible especially when vB says otherwise?
        Because it doesnt affect everyone. If you are affected, apply the supplied fix and move on.
        Baby, I was born this way

        Comment


        • #34
          Originally posted by Paul M View Post
          Because it doesnt affect everyone. If you are affected, apply the supplied fix and move on.
          My users have a lot of issues with CKEditor, and not only with iPhone (but with many browsers and SO). This is the worst update of ever of vBulletin (and i use vBulletin from 5 years!). I hope we can choose what editor to use in next vBulletin version so i can disable this horrible CKEditor.

          Comment


          • #35
            Originally posted by worried View Post
            I've said it over and over. Why does vB staff ignore my complaints?! 4.1.4 is completely buggy with FF 3.6. Specifically, cursor issues--that kind of bug sort of stares you in the face. I'm guessing there's still a lot of FF users with ver. 3.6 on their machine. Worst yet, you cannot post or edit with the iPhone/iPad/iTouch without changing the browser's default settings--your typical user isn't going to figure that out. I cannot post with my Motorola Droid either.
            I'm not allowed to upgrade my firefox at work so I have to use the old one.

            CKE drives me nuts in that version of Firefox. I hate vbulletin now.





            jk. but still.
            www.8thos.com

            Comment


            • #36
              any info for next bug fixes release?

              Comment


              • #37
                Originally posted by Octavius View Post
                I'm not allowed to upgrade my firefox at work so I have to use the old one.

                CKE drives me nuts in that version of Firefox. I hate vbulletin now.





                jk. but still.
                Chill. The fix is posted, or wait for 4.1.5 (like me). The new editor is fine and a joy to use.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.6.4 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #38
                  Originally posted by punchbowl View Post
                  the op has a point, it's a regression and afaik in the tracker. many people don't want to allow people upload images (of indeterminate copyright) to our sites. it's one thing hotlinking images, quite another downloading content from other peoples sites then uploading it to your own.
                  Originally posted by Steve Machol View Post
                  I'm confused. This works exactly the same way as the old editor in 4.1.3. What's the issue?
                  Originally posted by Loco.M View Post
                  I agree
                  Also I for one like the "upload this file to your website" option as do my members.
                  I'd rather host the files myself vs hosting them on another site which could delete them.
                  Ditto and you also have the issue of hot link bombing were you could end up with unaceptble content in old post and have no way to notice a change, you are efectivly letting any image host have the ability to edit your old post. I am not really concerned over copyright issues with web photos, I would comply with a take down notice, having the ability to watermark them would be great. (uploaded to example.com by rootsxrocks on 06/27/11)


                  Originally posted by Andy View Post
                  To achieve the behavior you want, all you have to do is set this option to No.

                  Admin CP -> Settings -> Options -> Message Attachment Options -> Advanced Insert Image Popup - Enable -> No
                  just moved the post below over here and I am going to have a look at the setting to see if what you are talking about is the issue. Insert Image Popup NO really sounds counter intuitive to the results if yes cause them to appear as links. Espesially if the lightbox is turned off and what you get is navigating away from the page to see the attachment in a seperate window.



                  Originally posted by Zachery View Post
                  http://tracker.vbulletin.com/browse/VBIV-12092 Upload the js file and overwrite the one on your server.

                  ICan anyone tell me what setting makes images appear in line. Instead of showing the links were the in the editor. you see something like this
                  [ATTACH=CONFIG]188643[/ATTACH][ATTACH=CONFIG]188644[/ATTACH][ATTACH=CONFIG]188645[/ATTACH][ATTACH=CONFIG]188646[/ATTACH][ATTACH=CONFIG]188647[/ATTACH] and the displayed post is a link with the name of the file.

                  I had this issue previously and upon fiddling with the settings eventually i got it to show me the image and the pop up formating window again but I am lost as to how I did it.
                  I am trying to help a Friend with a 4.14 install, mine is not 'Broke' right now but I really need to understand what is going on here before I upgrade.
                  I thought he had disabled the advance image uploader but it was in my usercp that the setting had reverted to the "simple" interface.

                  Is this part of the light box? or something to do with the display thumbnails ?
                  I had Ajax turned on previously and was still able to get the image but was unable to do mutiple files at once.
                  Designing Your Forum Around The Members Lifestyle becoming A Valuable Asset To The Community With VB Before Trying To Make A Buck.

                  Comment


                  • #39
                    Originally posted by Fabikus View Post
                    I hope we can choose what editor to use in next vBulletin version so i can disable this horrible CKEditor.
                    Hope all you like. Not happening though.
                    Last edited by Mark.B; Mon 27 Jun '11, 1:36pm.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.6.4 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #40
                      Originally posted by Mark.B View Post
                      Hoper all you like. Not happening though.
                      something I see different here than at the other 4.1.4 install is
                      here in our settings we have three selections
                      were on that one it is only the basic and standard would having the WYSIWYG disabled cause my issue mentioned above ig the ATTACH tag instead of an image ?
                      Message Editor Interface:
                      • Enhanced Interface - Full WYSIWYG Editing
                      • Basic Editor - A simple text box
                      • Standard Editor - Extra formatting controls
                      When posting messages to the forums or other members, there are three interface types available to you. The simplest of these is a simple text box, while the last is a fully-fledged WYSIWYG editor, which allows you to format your text as you want it and see the results immediately.

                      Depending upon the capabilities of your web browser, you may not be able to use all of these options. If you experience problems when posting messages, try switching to a different interface type.
                      Designing Your Forum Around The Members Lifestyle becoming A Valuable Asset To The Community With VB Before Trying To Make A Buck.

                      Comment


                      • #41
                        Originally posted by Zachery View Post
                        It is not causing issues for all users, we were not able to reproduce the bug locally before going live with the launch AFAIK.
                        Would really appreciate a reply to my post when you get a moment - https://www.vbulletin.com/forum/show...=1#post2178070

                        Thank you.

                        Comment


                        • #42
                          Originally posted by worried View Post
                          How is that possible especially when vB says otherwise?

                          http://tracker.vbulletin.com/browse/VBIV-12092

                          Myself and my members cannot post from the iphone. Other members can't post from their ipad. Did you install a patch?
                          Depends on your version of the iPhone and iOS software installed. I understand that people with the iPad 2 can post but those with the iPad 1 cannot. Apple builds a completely different firmware for each device and version of that device to cater to its hardware. So while people on the iPhone 4 on AT&T may not be able to post, those on the same phone but using Verizon may be able to. It is two different pieces of hardware and uses different versions of the operating system.

                          On a side note, no iOS device can support the Enhanced or Richtext editors on this site or anywhere else. There are rumors that the proper coding (content_editable) for such support is being added to iOS 5.0 which is due out later this year but it is currently in a closed developer only beta. As an iPad/iPhone user myself, I do hope this gets updated on Apple's end so that web developers can build in support within their applications.

                          I don't believe that Android phones support content_editable either.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API

                          Comment


                          • #43
                            Originally posted by Andy View Post
                            I didn't install the patch.

                            Please don't assume that the problem is true for everyone. If that were the case you would see a lot more confirmations in the JIRA report. Based on the few JIRA comments, my hunch is the problem only effects a few users.
                            Most licensed owners don't use bug tracker. If the problem affected Digital Point forums then it was significant. The bugs themselves are problematic but the condescending replies from staff and members like yourself are far more aggravating.

                            Comment


                            • #44
                              Originally posted by worried View Post
                              Most licensed owners don't use bug tracker.
                              Most licensed users dont post from iPhones either.

                              Originally posted by worried View Post
                              If the problem affected Digital Point forums then it was significant.
                              No more significant than any other forum. It didnt affect everyone, but then you already know that now.
                              Baby, I was born this way

                              Comment


                              • #45
                                Originally posted by Zachery View Post
                                What bugs make the CKEditor completely not useable?
                                Um the one where members can't post new threads, new posts etc no matter how many times you upload new vb files, no matter what browser they are using (had reports from both FF and Chrome) and no matter what type of editor we attempt to use.

                                I consider that un useable seem my site is now dead seem no one can post.

                                You type your thread click post and nothing happens not even a loading image or nothing it just sits there.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X