Announcement

Collapse
No announcement yet.

CMS comments don't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] CMS comments don't work

    Strange problem. People can only comment via the forum. Once worked, and haven't since changed any permissions...
    • When a registered user tries to comment from the CMS, the submit button doesn't "click" and nothing is posted.
    • When a guest attempts to, the button "clicks" but nothing is actioned.
    http://gamers-underground.com/conten...exclusive.html
    Last edited by InfoAddict; Wed 15 Jun '11, 10:14pm.

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

    define('DISABLE_HOOKS', true);

    As you use vBSEO, you will also need to disable this via it's own Control Panel and rename any relevant .htaccess files to ensure they're not being called.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      have you set the permissions for each group in the cms section of your admin panel

      Comment


      • #4
        Hawk2; yes, as per my initial post I have not changed my permissions, and people could once comment fine. I've double checked them and they are correct.

        Trevor; I've tried all of these steps, including creating a new style, and the problem still exists.

        Comment


        • #5
          Your javascript isn't being loaded for some reason on that page. Either you haven't uploaded it, or the permissions are incorrect for it or you have some redirects (htaccess) in place that is causing the issue:

          Code:
          Failed to load source for: http://js.gamers-underground.com/clientscript/ckeditor/ckeditor.js?t=A7HG4HT&v=414
          and
          Code:
          Failed to load source for: http://js.gamers-underground.com/clientscript/vbulletin_textedit.js?v=414

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools &lt;- awesome site for html/css help

          Comment


          • #6
            Hi Lynne, thanks! Fixing our Javascript calls fixed the problem, mostly.

            Logged out/unregistered users could comment (as they are only given the standard controls comment box).

            However normal registered users could not comment if the WYSIWYG box was enabled. It was erroring on line 134 of ckeditor.js when they clicked "Add Comment", which references smilies.

            Rather than trouble-shoot this, I just disabled smilies for all areas except the forum specifically, and that fixed the problem.

            Comment


            • #7
              You cannot use smilies that have a ( or ) in the file name. So, go through your smilies and, if needed, rename them to something that doesn't have a ( or ) in the file name. You will have to do that on your server and in the Smilie Manager.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools &lt;- awesome site for html/css help

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X