Announcement

Collapse
No announcement yet.

New Editor Not showing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] New Editor Not showing

    I just upgraded my test site to 4.1.4, and the editor doesn't show. It flashes for a second, and I get a blank screen. I've tested in Firefox, Chrome and IE. Same result. Screenshot is attached Click image for larger version

Name:	no-editor.jpg
Views:	1
Size:	32.8 KB
ID:	3720730

  • #2
    First, make sure you have the WYSIWYG Editor enabled here:

    Admin CP -> Settings -> Options -> Message Posting Interface Options -> Enable Clickable Message Formatting Controls

    Then make sure you have selected the Enhanced editor in your user Settings:

    Settings -> Edit Options -> Message Editor Interface -> Enhanced Interface

    If you see the editor without the images, then this means you have not uploaded the 4.1.4 'images/editor/sprite.png' file. You need to do that.

    If you still have this problem after that, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      When you say " Enhanced editor" or " Enhanced Interface", I assume you mean "Enable Standard and WYSIWYG Controls". If so, I have done everything above and still no interface - even after I disabled all plugins

      Comment


      • #4
        I've got same problem on my website. I tried Default Style too.

        Comment


        • #5
          I'm subscribing to this, default style/template and have the same issue.

          Comment


          • #6
            Ok, I fixed my forums.

            If you're using your own style. Please, upload images from \Upload\images\editor\ to \images\YOUR_SKIN_NAME\editor\. You must reset your cache in internet browser too.

            Comment


            • #7
              I've tried in all three main browsers as well.

              Comment


              • #8
                Updated my old post.

                Comment


                • #9
                  There are several of you posting in this thread that have a problem. It is very hard to follow who has done what when you are all posting in here. It is much better if you create your own thread and post what your problem is and what you have tried to solve it.

                  Please don't PM or VM me for support - I only help out in the threads.
                  vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                  Want help modifying your vbulletin forum? Head on over to vbulletin.org
                  If I post CSS and you don't know where it goes, throw it into the additional.css template.

                  W3Schools <- awesome site for html/css help

                  Comment


                  • #10
                    Ok fine, then I'll just open a support ticket in the members portal then I'll tell them you sent me.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X