Announcement

Collapse
No announcement yet.

Google +1 Button Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Originally posted by Apolo View Post
    Well... maybe I'm not getting all the power from the .htaccess file because issue #1 is still there: both Google +1 and Facebook Like will treat these links as different pages:

    www.domain.com
    www.domain.com/index.php

    And that's the main reason why I'm pointing this issue out. Sure, when I enable the .htaccess redirect back again, the URL is redirected from domain.com to www.domain.com, but / and index.php are being treated as different pages by both Google +1 and Facebook Like.
    This is how it should be because they can be different pages. I could assign priority to show .html or .aspx first if I wanted to. Heck I could even tell it to use index.rtf as my default page. In fact your server is probably configured right now to show index.html first and then go through a list of other options including index.php.

    Set up your .htaccess to 301 redirect /index.php to /. Or the other way around. You choose.
    Last edited by Wayne Luke; Wed 29th Jun '11, 11:26am.

    Leave a comment:


  • Apolo
    replied
    Originally posted by Dirt Bike Addict View Post
    In that case issue #1 isn't really valid anymore as the .htaccess would fix the problem before it even gets to Google +1.
    Well... maybe I'm not getting all the power from the .htaccess file because issue #1 is still there: both Google +1 and Facebook Like will treat these links as different pages:

    www.domain.com
    www.domain.com/index.php

    And that's the main reason why I'm pointing this issue out. Sure, when I enable the .htaccess redirect back again, the URL is redirected from domain.com to www.domain.com, but / and index.php are being treated as different pages by both Google +1 and Facebook Like.

    Leave a comment:


  • Dirt Bike Addict
    replied
    Originally posted by Apolo View Post
    I disabled the .htaccess redirect temporarily for (these) testing purposes. : )
    Ok that makes sense now. In that case issue #1 isn't really valid anymore as the .htaccess would fix the problem before it even gets to Google +1.

    Leave a comment:


  • Apolo
    replied
    Originally posted by Dirt Bike Addict View Post
    Can you post (or PM) your URL? It just seems odd that it would pick up a different URL (no www) if your .htaccess is working right.
    I disabled the .htaccess redirect temporarily for (these) testing purposes. : )

    Leave a comment:


  • Dirt Bike Addict
    replied
    Originally posted by Apolo View Post
    even by having those "fixes" in place, Google +1 believes that domain.com or www.domain.com are different from domain.com/index.php or www.domain.com/index.php. How can we fix that?
    Can you post (or PM) your URL? It just seems odd that it would pick up a different URL (no www) if your .htaccess is working right.

    Leave a comment:


  • Apolo
    replied
    Originally posted by Dirt Bike Addict View Post
    Issue #1
    I'd recommend choosing either domain.com or www.domain.com and sticking with it. Use .htaccess to redirect your links to the preferred one. Plus also let Google know which one you prefer in your webmaster settings.

    Google Webmaster Tools > Site Configuration > Settings > Preferred domain
    Thanks for your reply. Yes, the preferences were already set on Google Webmaster Tools. And yes, we'll stick with the www.domain.com version by using a redirect from domain.com. I just wanted to point that issue out and the main one: even by having those "fixes" in place, Google +1 believes that domain.com or www.domain.com are different from domain.com/index.php or www.domain.com/index.php. How can we fix that?

    Originally posted by Dirt Bike Addict View Post
    Issue #2
    I've also noticed this, not sure if there's a fix though.
    +1

    Leave a comment:


  • Dirt Bike Addict
    replied
    Issue #1
    I'd recommend choosing either domain.com or www.domain.com and sticking with it. Use .htaccess to redirect your links to the preferred one. Plus also let Google know which one you prefer in your webmaster settings.

    Google Webmaster Tools > Site Configuration > Settings > Preferred domain

    Issue #2
    I've also noticed this, not sure if there's a fix though.

    Leave a comment:


  • Apolo
    replied
    Hi,

    I don't know if this topic is appropiate to share with you two similar issues I'm currently facing on one of my forums. If not, please bear with me and let me know the right forum to deal with these issues. If yes, I'd really appreciate if you could please shed some light in here.

    Issue #1

    For Google +1, these are all different links:

    domain.com
    www.domain.com
    domain.com/index.php
    www.domain.com/index.php

    So no matter they are in fact the same page, you can add +1 to each of them and Google will treat them as 4 different pages for their +1 count.

    For Facebook Like, these are the same links:

    domain.com/index.php
    www.domain.com/index.php

    So the Likes count will be the same either case.

    But if you remove the "index.php" at the end, Facebook will treat them as different pages.

    Issue #2

    When your thread has more than one page, both Google +1 and Facebook Like will treat them as different pages. I know in this case they are really different pages, but it would be nice if both Google +1 and Facebook Like would count for the whole thread, as it is a single topic either way.

    Thank you!!

    Leave a comment:


  • Wayne Luke
    replied
    Please see this related issue: http://tracker.vbulletin.com/browse/VBIV-6335

    Leave a comment:


  • bszopi
    replied
    Woohoo! Worked for me as well. Thanks!

    Leave a comment:


  • Dirt Bike Addict
    replied
    Originally posted by Wayne Luke View Post
    Haven't been able to determine if not having the full URL is a bug myself yet.
    It is, I just created a "stock" vb install and tried the Google +1, which of course didn't work on threads. However after making the above changes to the canonical URL it now works.


    Find this in your showthread template:
    Code:
    <link rel="canonical" href="{vb:raw thread_url}" />

    And replace it with this:
    Code:
    <link rel="canonical" href="{vb:raw vboptions.bburl}/{vb:raw thread_url}" />

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by Dirt Bike Addict View Post
    So the reason Google +1 doesn't work on stock vB is because the Canonical URL doesn't show the full path? (ea. http://www.yourdomain.com/forum/showthread.php vs. /forum/showthread.php)
    Seems that way according to this thread. Haven't been able to determine if not having the full URL is a bug myself yet. I am inclined to say it is but haven't seen anything definitive. I did change the canonical URL on my site though.

    Leave a comment:


  • Dirt Bike Addict
    replied
    So the reason Google +1 doesn't work on stock vB is because the Canonical URL doesn't show the full path? (ea. http://www.yourdomain.com/forum/showthread.php vs. /forum/showthread.php)

    Leave a comment:


  • Wayne Luke
    replied
    You can set the code for the Canonical URL to look like this:

    Code:
    <link rel="canonical" href="{vb:raw vboptions.bburl}/{vb:raw thread_url}" />

    This way if you use the style on another site or change your domain name for any reason, it will automatically update.

    Leave a comment:


  • Destron
    replied
    Originally posted by MEsh3L85 View Post
    does it help ?
    Thanks, that seemed to fix the issue, I can now use the google +1 button in my threads.

    Leave a comment:

Related Topics

Collapse

Working...
X