Announcement

Collapse
No announcement yet.

Embed MP3 Audio into forum post

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Embed MP3 Audio into forum post

    can anyone share how to embed an mp3 audio file (like an interview) into a post for my forum?

    i am using 4.1.4 and i tried the <embed> code but it doesn't actually play the mp3 - it just hangs on the quicktime logo.

    is there another way of embedding it or using a plugin/mod to do this?

  • #2
    I would just attach it to the post, let your users download it.

    Comment


    • #3
      Originally posted by Zachery View Post
      I would just attach it to the post, let your users download it.
      thanks. what i ended up doing [for now] is i linked it directly to the amazon S3 file which opens in a new window with the mp3 player in there. wasn't too keen on attaching it to the post as i have lots of them and don't want that to eat my server!

      thanks for your help

      Comment


      • #4
        Example like this looks nice as embeded player: http://www.tabletennistalk.co.uk/for...etime-PingPong

        Add BB Code:

        Title: MP3
        BB Code Tag Name:MP3 Player

        Replacement (change bold values to your paths):
        <object type="application/x-shockwave-flash" data="/audio/player.swf" id="audioplayer" height="24" width="290">
        <param name="movie" value="/audio/player.swf">
        <param name="FlashVars" value="playerID=audioplayer&amp;soundFile={param}">
        <param name="quality" value="high">
        <param name="menu" value="false">
        <param name="wmode" value="transparent">
        </object>

        Example:[mp3][/mp3]
        Use {option}: no
        Remove Tag If Empty:yes
        Disable BB Code Within This BB Code:yes
        Disable Smilies Within This BB Code:yes
        Disable Word Wrapping Within This BB Code:yes
        Disable Automatic Link Parsing Within This BB Code:no

        Download attatched player and image


        Attached Files
        www.tabletennistalk.co.uk

        Comment


        • #5
          hey basilrath thanks a lot for that, appreciate it.

          1) where do I upload player.swf within the vB files?

          2) image attachment to your post didn't work...and where does that go?

          i can create the custom bb code but just need to know where the player file goes?

          Comment


          • #6
            The best way is simply to upload to your root in other words keep it in the audio file

            so unzip
            upload the audio folder to root

            then adjust bold paths to your site ie..........

            make sure the paths are correct

            <object type="application/x-shockwave-flash" data="www.yoursite.com/audio/player.swf" id="audioplayer" height="24" width="290">
            <param name="movie" value="www.yoursite.com/audio/player.swf">
            <param name="FlashVars" value="playerID=audioplayer&amp;soundFile={param}">
            <param name="quality" value="high">
            <param name="menu" value="false">
            <param name="wmode" value="transparent">
            </object>


            image ...Click image for larger version

Name:	mp3_bb.png
Views:	3
Size:	1.2 KB
ID:	3682490
            www.tabletennistalk.co.uk

            Comment


            • #7
              thanks so much buddy, really appreciate your response.

              Comment


              • #8
                mmh ok i did all of the above but the player still doesn't show. i know its uploaded ok because i can go to it in my browser when i type in the address but on the post it isn't showing up....

                BB codes are on so it's not that and i double checked all the custom bb code settings too..
                any ideas?

                Comment


                • #9
                  PM me your board details ill look now

                  by the way you did but the replacement in ???

                  Example:[mp3][/mp3]


                  when you post the the mp3 in your post it would look like this

                  [mp3]path to your mp3 file[/mp3]
                  www.tabletennistalk.co.uk

                  Comment


                  • #10
                    Hi Basilrath, I've just been asked by a member of my board for a way to add Mp3's and found your instructions. I've done as you ask and the message

                    The following BB Code replacement may not be properly formed. All HTML attributes should be enclosed within double quotes.

                    <object type="application/x-shockwave-flash"
                    data="www.xxxxxxxx.co.uk/audio/player.swf" id="audioplayer" height="24"
                    width="290"> <param name="movie" value="www.xxxxxxxx.co.uk/audio/player.swf">
                    <param name="FlashVars" value="playerID=audioplayer&amp;soundFile={param}"> <param
                    name="quality" value="high"> <param name="menu" value="false"> <param name="wmode" value="transparent"> </object>


                    The bold {param} is what is highlighted and what I'm guessing is the problem. Any idea what the issue is?

                    Thanks in advance

                    Comment


                    • #11
                      Where are you getting the error?

                      Comment


                      • #12
                        Hi Zachery, thanks for your response,

                        It says it when I go to save the BB code, it says vBulletin Message 'The following BB Code replacement may not be properly formed. All HTML attributes should be enclosed within double quotes.' and then that posted above

                        Comment


                        • #13
                          did you test it? If its working fine, its working fine.

                          Comment


                          • #14
                            I tried but it isn't showing anywhere on the post box

                            Comment


                            • #15
                              So I know this is old but I need to do this and it is not working.

                              I am trying to do it on a local copy for my forum.

                              Here is my info:

                              <object type="application/x-shockwave-flash" data="/forum/audio/player.swf" id="audioplayer" height="24" width="290">
                              <param name="movie" value="/forum/audio/player.swf">
                              <param name="FlashVars" value="playerID=audioplayer&amp;soundFile={param}">
                              <param name="quality" value="high">
                              <param name="menu" value="false">
                              <param name="wmode" value="transparent">
                              </object>
                              Rest is set as you described. I copied a "test.mp3" to my localhost at /forum/audio/test.mp3

                              My post looks like this and I have tried a kinds of iterations with no luck.

                              [mp3]/forum/audio/test.mp3[/mp3]

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X