Announcement

Collapse
No announcement yet.

Invalid Url Error While Insert Image Link

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Invalid Url Error While Insert Image Link

    Hi guys after i update vb to last version this problem occured.

    Steve said maybe that causing due modifications i've disabled all modifications but problem still going on.

    Click image for larger version

Name:	Adsız.jpg
Views:	1
Size:	51.4 KB
ID:	3720701

  • #2
    Assuming that is a valid link this has to be either from a modification, a missing fine or a server issue.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem? If so, you need to contact your host about this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      When i did this :

      Admin CP -> Settings -> Options -> Message Attachment Options -> Advanced Insert Image Popup - Enable -> Yes


      and unmark "Retrieve remote file and reference locally" this option then i able to insert image link.

      So how i could unmark this option default ?Click image for larger version

Name:	Adsız.jpg
Views:	1
Size:	39.8 KB
ID:	3682481

      Comment


      • #4
        I too have the same problem
        Is there a solution, despite all the attempts I did ؟؟

        Comment


        • #5
          You can merge this 2 posts.

          https://www.vbulletin.com/forum/show...On-Image-4.1.4

          I have same problem and other people have same problem and in this forum to.

          Best Regards

          Comment


          • #6
            I managed to do a temp fix until vb releases a update.

            See HERE for a working FIX.
            https://www.vbulletin.com/forum/show...=1#post2170729

            Comment


            • #7
              The bug report for this issue is here - http://tracker.vbulletin.com/browse/VBIV-12369

              Vote on it and Watch it.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools <- awesome site for html/css help

              Comment


              • #8
                I don't use the Asset Manager OR Advanced Insert Image Popup! My URL images do not work! Invalid URL!
                snerd

                Comment


                • #9
                  Any update on this bug? Not being able to link to images is major fail.
                  snerd

                  Comment


                  • #10
                    Originally posted by snerd View Post
                    I don't use the Asset Manager OR Advanced Insert Image Popup! My URL images do not work! Invalid URL!
                    If you don't use the advanced image pop-up, just open /clientscript/ckeplugins/vbimage/dialogs/image.js
                    Find
                    Code:
                    if (dialog.getContentElement('from_url', 'remote_file').getValue())
                    {
                        ...
                    }
                    else
                    {
                        this.editor.insertHtml('[IMG]'+url+'[/IMG]');
                    }
                    Remove or comment out all ... code in the if clause and replace it with the same line of code as in the else clause.

                    Make sure you clean your browser cache and it should work
                    Minatica.be - Belgian/Dutch computer and technology site
                    DownloadsII - Add a downloads database to your vB 4

                    Comment


                    • #11
                      Thanks, that worked.

                      Originally posted by RS_Jelle View Post
                      If you don't use the advanced image pop-up, just open /clientscript/ckeplugins/vbimage/dialogs/image.js
                      Find
                      Code:
                      if (dialog.getContentElement('from_url', 'remote_file').getValue())
                      {
                          ...
                      }
                      else
                      {
                          this.editor.insertHtml('[IMG]'+url+'[/IMG]');
                      }
                      Remove or comment out all ... code in the if clause and replace it with the same line of code as in the else clause.

                      Make sure you clean your browser cache and it should work
                      snerd

                      Comment


                      • #12
                        Originally posted by snerd View Post
                        Any update on this bug? Not being able to link to images is major fail.
                        Try this.

                        Originally posted by Fragmasters View Post
                        FIXED Image.js (see attachment image)

                        Here is what I did;

                        1. DOWNLOAD and unzip the file Image.zip

                        2. REPLACE the file clientscript/ckeplugins/vbimage/dialogs/image.js with the unzipped version of image.js (BACKUP YOUR OLD VERSION)

                        3. ENABLE Advanced Insert Image Popup

                        Admin CP -> Settings -> Options -> Message Attachment Options -> Advanced Insert Image Popup - Enable -> Yes

                        Comment


                        • #13
                          Originally posted by Fragmasters View Post
                          Try this.
                          Why would I want to join your forum just to download this fix? Thanks anyway.
                          snerd

                          Comment


                          • #14
                            Originally posted by Steve Machol View Post
                            Assuming that is a valid link this has to be either from a modification, a missing fine or a server issue.

                            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                            Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

                            Admin CP -> Plugins & Products -> Manage Products -> Disable

                            Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

                            Admin CP -> Plugins & Products -> Plugin Manager

                            You must do BOTH of those steps in order to disable all non vBulletin Modifications.

                            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                            Do you have the same problem? If so, you need to contact your host about this.

                            there's nothing to do with this, as well as forum modification I guess. It also happens when I test it on a fresh new forum on local server (XAMPP). Still can't post any images. it said Invalid URL.

                            Comment


                            • #15
                              Please config in your server (File php.ini) enable fsockopen , Remove this in file php.ini. You will attach the photo or file from URL
                              If you use a host, please contact your hosting provider
                              www.mocua.com | www.mocua.net | www.phiencho.com

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X