Announcement

Collapse
No announcement yet.

vb 4.1.4 apache server error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] vb 4.1.4 apache server error

    I just upgraded the vbulletin 4.1.4, however I cannot access my forums without disabling all hooks via config.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at flotgaming.net Port 80


    I can access my forums only by disabling all hooks, and in this form 4.1.4 seems to run fine. Communicating to my host comes back with the error logs:
    [Fri Jun 10 15:47:38 2011] [error] [client 24.32.234.213] Premature end of script headers: index.php, referer: http://flotgaming.net/homepage/
    [Fri Jun 10 15:47:39 2011] [error] [client 24.32.234.213] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/homepage/
    [Fri Jun 10 15:48:27 2011] [error] [client 193.105.210.45] Premature end of script headers: index.php, referer: http://flotgaming.net/forums/index.php
    [Fri Jun 10 15:48:27 2011] [error] [client 193.105.210.45] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/forums/index.php
    [Fri Jun 10 15:48:29 2011] [error] [client 193.105.210.45] Premature end of script headers: index.php, referer: http://flotgaming.net/forums/index.php
    [Fri Jun 10 15:48:29 2011] [error] [client 193.105.210.45] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/forums/index.php
    [Fri Jun 10 15:48:30 2011] [error] [client 193.105.210.45] Premature end of script headers: content.php, referer: http://flotgaming.net/forums/content...-APPLY-TO-FLOT
    [Fri Jun 10 15:48:31 2011] [error] [client 193.105.210.45] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/forums/content...-APPLY-TO-FLOT
    [Fri Jun 10 15:48:31 2011] [error] [client 193.105.210.45] Premature end of script headers: content.php, referer: http://flotgaming.net/forums/content...er-Info-Status
    [Fri Jun 10 15:48:32 2011] [error] [client 193.105.210.45] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/forums/content...er-Info-Status
    [Fri Jun 10 15:48:33 2011] [error] [client 193.105.210.45] Premature end of script headers: downloads.php, referer: http://flotgaming.net/forums/downloads.php
    [Fri Jun 10 15:48:33 2011] [error] [client 193.105.210.45] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/forums/downloads.php
    [Fri Jun 10 15:48:34 2011] [error] [client 193.105.210.45] Premature end of script headers: content.php, referer: http://flotgaming.net/forums/content.php?96
    [Fri Jun 10 15:48:34 2011] [error] [client 193.105.210.45] Premature end of script headers: 500_forum.php, referer: http://flotgaming.net/forums/content.php?96


    Now a few of those looks like a incompatible addons, but then there are pages like content.php and index.php which are native vbulletin pages?


    I mentioned the apache mod_security to my host but they said it would return a denied access error not the 500 Internal Server Error. Please assist.
    sigpic

  • #2
    https://www.vbulletin.com/forum/show...14#post2169714
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Reading now, Thanks.

      A lot of those point to the possibility of the script itself,

      content.php
      index.php
      500_forum.php (not sure on this one)

      are all vBulletin files? should these files have special permissions beyond 644? in vbulletin 4.1.4 or anything change from 4.1.3 that would have me do something special this go around?
      sigpic

      Comment


      • #4
        Sorry, that's the file I meant. It's not a vB file. It looks like you have a server issue affecting all those files.

        Permissions requirements have not changed.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          content.php and index.php are vbulletin files? the address after is just the referring page no?

          My host sends me to vbulletin and you send me to my host. What would you suggest I tell them needs to be done for these files to function.
          sigpic

          Comment


          • #6
            I would tell then to investigate and resolve the 'Premature end of script headers' errors. This is a server issue.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Latest from my host, who i've been working.

              Hello there!

              Your program is causing a segmentation fault in PHP. There is a possible solution: reupload your forum files, and make sure your FTP program is force set to BINARY mode instead of ASCII mode. If this doesn't work, you will need to contact the developer of your forum, as we do not directly support this software.

              Let us know if there is anything else we can help you with!

              [[email protected] /home/flot/public_html/forums]# php index.php
              Segmentation fault (core dumped)
              I've re-uploaded the files making sure I was in Binary mode this time, no effect.

              So please, is there a software issue I should look at, or is HostGator simply incapable of hosting the latest version of vbulletin 4.1.4
              sigpic

              Comment


              • #8
                Additionally:

                I am able to use and navigate to the Vbulletin CMS (from our homepage non-vbulletin portal) even with all plugins and hooks disabled?

                The only thing disabling all plugins and hooks does, is remove the cms navbar link. In addition to disabling all other addons of course.

                So I'm confused in what fashion index.php is causing with the server, if I can utilize it fine with plugins and hooks disabled but the moment I enable the default vbulltin cms via radio button, or config.php (through plugins and hooks) all hell breaks lose.

                What I mean to say is, how does the behavior of index.php change with the CMS enabled vs not enabled. Because in this change, our site ceases to function.
                Last edited by Crotan; Sun 12th Jun '11, 7:41pm.
                sigpic

                Comment


                • #9
                  All PHP files should be uploaded in ASCII mode, not Binary.

                  Assuming you have uploaded the vB files correctly, this is still a server issue.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol View Post
                    All PHP files should be uploaded in ASCII mode, not Binary.

                    Assuming you have uploaded the vB files correctly, this is still a server issue.
                    Please see my changes to my post above (edited at 10:41)
                    sigpic

                    Comment


                    • #11
                      There is nothing in the default vB files - including index.php - that would cause 'segmentation faults'.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Well here's my issue, I have all plugins disabled. The site runs fine, and index.php is accessible, I can view articles and everything as long as I know the address (http://flotgaming.net/forums/index.php) or use a non vbulletin referrer page. If I enable a single plugin, but leave everything else disabled. Be it the CMS or Blog, any vbulletin page will load with the "Internal Server Error" message in my first post.

                        As a tertiary question, what does disabling the CMS in the plugins manger do besides removing the CMS navbar link?

                        nvm I think I discovered a bug here:

                        Because using the global "This setting allows you to globally enable or disable the plugin/hook system." does not disable the cms only removes the navbar link, only way to disable the cms is via disabling it in the list. Using the config edit method or plugin disable all radio button does not. I think I'm getting hung up on that
                        sigpic

                        Comment


                        • #13
                          I recently upgraded to vbulletin 4.1.4 and I am having similar kind of problem but only with search.php file, everything is working fine except search.php furthermore I have uploaded it many times but still no luck, I run the "check suspected file" tool and it's saying that search.php don't have expected contents, I just re-downloaded vbulleting and again uploaded search.php file but still getting same "internal server error" long with premature hearders end message in apache error log.
                          Best Regards,
                          Bilal

                          Comment


                          • #14
                            'Internal Server Errors' are server issues. Contact your host.

                            Also for future reference, please start your own thread for your specific issue. Thank you.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              ^ I administrate my own servers :S and all other websites are working fine even yesterday night my vb 4.1.3 was working fine as well..anyway I made the modification to my search.php file and it's working like a charm now, thanks to the code provided by ppc2you here: https://www.vbulletin.com/forum/show...arch.php/page2 and yeah sorry for hijacking this thread :$
                              Best Regards,
                              Bilal

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X