Announcement

Collapse
No announcement yet.

CKEditor: No button Images anywhere.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] CKEditor: No button Images anywhere.

    Is this normal? Have the button images been abandoned for 4.1.4? I've just upgraded my forum to 4.1.4 and notice that none of the Editor buttons have images anymore. I am also seeing that on this forum. I've tried on Firefox and IE9 with the same result.

    Went in and had a peek in the stylevars to see if the imagepaths had changed, but nothing has. Editor button images are still pointing to where they were when it was working on 4.1.3.

    I am confused... I'm also going to have to figure out how to change the editor and text area colors as well...

  • #2
    You are seeing that on these forums? Can you post a screen pic?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Do you have javascript turned off in your browser?

      Comment


      • #4
        Certainly. Here's what I'm seeing right now.
        Click image for larger version

Name:	nobuttons.jpg
Views:	1
Size:	94.5 KB
ID:	3682464
        I have no idea what could be going on here.

        Comment


        • #5
          I've got exactly the same issue. Upgraded from 4.1.3 to 4.1.4 and no images show in the editor! This is how mine looks:



          Any ideas on what is causing this, or how to fix it?

          Thanks in advance.
          Xbox 360 Forums

          Comment


          • #6
            Originally posted by Daryn View Post
            Certainly. Here's what I'm seeing right now.
            [ATTACH=CONFIG]53150[/ATTACH]
            I have no idea what could be going on here.
            If you are seeing that on our forums, then the issue is on your end. It's impossible to know exactly what it is but some possibilities are: browsers, browser settings, cookies being blocked, Internet and security settings, ISP and/or cache issues, firewalls, ad-blockers, spyware, proxies and any other application that affects Internet content.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Ross L View Post
              I've got exactly the same issue. Upgraded from 4.1.3 to 4.1.4 and no images show in the editor! This is how mine looks:



              Any ideas on what is causing this, or how to fix it?

              Thanks in advance.
              Please start your own thread with all the relevant details. Thank you.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol View Post
                If you are seeing that on our forums, then the issue is on your end. It's impossible to know exactly what it is but some possibilities are: browsers, browser settings, cookies being blocked, Internet and security settings, ISP and/or cache issues, firewalls, ad-blockers, spyware, proxies and any other application that affects Internet content.
                Browsers I tested are Firefox 4, IE9, and Chrome. Firefox and IE have the problem, Chrome doesn't. My settings are more or less stock. I have some extensions on my Firefox to switch Colors on and off. IE9 is stock. Not using any ad-blockers and I have no spyware. I keep a clean system. As for the rest, I couldn't say. All I know is that since you moved to the 4.1.4 Beta I have never seen images on the editor buttons.

                ON my own site, I still don't see any images in either Firefox or IE, but do in Chrome. I'm at a loss.
                Last edited by Daryn; Fri 10th Jun '11, 2:47pm.

                Comment


                • #9
                  Revert your imgdir_editor stylevar.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    Originally posted by Wayne Luke View Post
                    Revert your imgdir_editor stylevar.
                    Tried that already. No change.

                    Comment


                    • #11
                      Originally posted by Daryn View Post
                      Browsers I tested are Firefox 4, IE9, and Chrome. Firefox and IE have the problem, Chrome doesn't.
                      I suggest uninstalling Firefox completely. There is a checkbox during the uninstall process that removes all you personal configurations, bookmarks etc.. But before you do that export your bookmarks so you don't loose them. Then reinstall Firefox, at this point you should have zero addons. Does that work?

                      Comment


                      • #12
                        revert your editor.css file. In case you had any changes in there it may not have been able to merge it with the new version. This worked for me.

                        Comment


                        • #13
                          Okay, I see what is happening now. At least as far as my particular instance goes.

                          There is a checkbox in Firefox's colors area that says "Allow Pages to choose their own colors..." which I turn off for Accessibility. When it's on (as it is by default) I get the images on the buttons. When it's off, CKEditor swaps the images for text links. So it seems like it's "not a bug, but a feature".

                          Comment


                          • #14
                            I've tried the above and still get this any ideas



                            Thanks in advance

                            Comment


                            • #15
                              Originally posted by UKCE_Hitman View Post
                              I've tried the above and still get this any ideas

                              Thanks in advance
                              Create a new style with no parent:
                              • Styles & Templates > Style Manager > Add New Style
                              • Parent Style: No Parent Style
                              • Title: Default vBulletin
                              • Allow User Selection: Yes
                              • Save


                              Then browse the site using that totally default vbulletin style - do you still have the same problem?

                              Please don't PM or VM me for support - I only help out in the threads.
                              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                              Want help modifying your vbulletin forum? Head on over to vbulletin.org
                              If I post CSS and you don't know where it goes, throw it into the additional.css template.

                              W3Schools <- awesome site for html/css help

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X