Announcement

Collapse
No announcement yet.

Prevent Code Tags from Wrapping Long-Lines

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Prevent Code Tags from Wrapping Long-Lines

    Hi everyone
    I have an issue that cropped up after upgrading to vB 4 from vB 3.8. Long lines of code now wrap instead of just presenting me with horizontal scrollbars. You can see an example here.

    Does anybody know how to prevent the wrapping and go back to the older behavior?

    Thanks,
    Kirupa

  • #2
    Can you be more specific? I don't see that in your link.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve,
      I've posted screenshots of what the code snippets look like in the latest versions of Chrome, Firefox, and IE:

      Chrome

      Click image for larger version

Name:	chrome_code.PNG
Views:	1
Size:	10.7 KB
ID:	3682367


      IE

      Click image for larger version

Name:	ie_code.PNG
Views:	1
Size:	11.7 KB
ID:	3682369

      Firefox

      Click image for larger version

Name:	ff_code.PNG
Views:	1
Size:	8.5 KB
ID:	3682368

      Notice that the text is inconsistently wrapping.

      Thanks,
      Kirupa

      Comment


      • #4
        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

        Admin CP -> Plugins & Products -> Manage Products -> Disable

        Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

        Admin CP -> Plugins & Products -> Plugin Manager

        You must do BOTH of those steps in order to disable all non vBulletin Modifications.

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi Steve,
          Sorry for the delay in getting back on this. I've tried all of your suggestions, and none of them worked. As a final resort, I created a test thread on the vBulletin Forums itself: https://www.vbulletin.com/forum/show...85#post2190685 (you may need to resize the browserto get the scrollbars to appear)

          The text wraps in weird combinations in all of the browsers.

          Thanks,
          Kirupa

          Comment


          • #6
            Thanks. I consider that a bug. The PHP code should not wrap. Please report this in the vB4 Bug Tracker here:

            http://tracker.vbulletin.com/secure/Dashboard.jspa
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              A link to your forum sure would be nice. I have an idea of what it is but want to take a look at the enviroment the code block is sitting in before I speak.
              ...

              Comment


              • #8
                setishock - I posted the link in the first post, but the link isn't noticeable :P Here is an updated link: http://www.kirupa.com/forum/showthre...=1#post2620413

                Comment


                • #9
                  ...

                  Comment


                  • #10
                    It's NOT a bug! You have 2 ads parked on the right side of the forum and that's chewing up a lot of real estate. That in turn is added to the fact your forum is sooooooooooooooooooooo narrow the box can not flair out like it's supposed to. Either dump the ads or make the forum a lot wider than you have it now.
                    @Andy I take it you saw what I did or you having one of those days too?
                    Attached Files
                    ...

                    Comment


                    • #11
                      Originally posted by setishock View Post
                      It's NOT a bug! You have 2 ads parked on the right side of the forum and that's chewing up a lot of real estate.
                      Even so, the PHP code should not have wrapped. It should have worked just like the Code function in that regard.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        setishock - I made a minor CSS tweak on my forums that fixes it only in Firefox but repros in Chrome and IE. Anyway, you can see the other URL I posted of this issue repro'ing in the forums here as well: https://www.vbulletin.com/forum/show...85#post2190685

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X