Announcement

Collapse
No announcement yet.

Sitemap for Webmaster Tools with friendly URLs the correct way

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Sitemap for Webmaster Tools with friendly URLs the correct way

    Hi, I am trying to make things work with no luck.

    The URL of the sitemap is http://www.site.com/forum/xmlsitemap.php and I have the friendly URLs advanced selected.

    Webmaster Tools drops a yellow attention sign that its not working .

    How to fix this ?


    Thanks.

  • #2
    What does it say the actual error is?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Theres no error at all. But its not working, I mean theres no error explained or something.

      Green check that its working, an attention icon and a red X. All my other sitemaps are green and ok, this one is not working tho. Without having the friendly advanced URLs I kind of remember it was working, but not sure.

      Any idea why is not working as it should ?

      Comment


      • #4
        If you open one of the XML files, what do you see as the links? Are they correct?
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          Ok, digging a little I see theres a huge problem with the sitemap.

          I have this:

          - 25,270 Duplicate meta descriptions
          - 19,680 Duplicate title tags

          Now, thats a big problem.

          Example of 1 thread:
          /forum/showthread.php/7054-Interconexión-de-2-MacBooks-Pro
          /forum/showthread.php?7054-Interconexi%F3n-de-2-MacBooks-Pro&p=51018&viewfull=1
          /forum/showthread.php?7054-Interconexi%F3n-de-2-MacBooks-Pro&p=51038&viewfull=1
          /forum/showthread.php?7054-Interconexi%F3n-de-2-MacBooks-Pro&p=51038

          It should be just the fist one and not 4 of them pointing to the same thread.

          That multiplied for 25,000 !

          It looks like the sitemap has URLs for non friendly URLs, for Friendly URLs and for archive or something ? And all of them pointing to the same place.

          As the friendly URLs are the correct ones, how to fix this issue in the sitemap ?

          Thanks.

          Comment


          • #6
            Can anyone help with this please ?

            Thanks.

            Comment


            • #7
              Are these all in your sitemap when you open the XML file?
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                As Webmaster Tools is reading them, yes, they are.

                If I open the "/forum/xmlsitemap.php?fn=vbulletin_sitemap_thread_0.xml.gz " file I found "/forum/showthread.php/7054-InterconexiÛn-de-2-MacBooks-Pro" which is different from the duplicated ones, so theres something in the sitemap causing this.

                How to fix it ?


                Thanks.

                Comment


                • #9
                  Can anyone help with this ?

                  Having all that duplicates is really bad.

                  Instead of this:

                  /forum/archive/index.php/t-3553.html?
                  /forum/showthread.php/3553-this-is-the-thread/page2
                  /forum/showthread.php/3553-this-is-the-thread/page3
                  /forum/showthread.php/3553-this-is-the-thread/page4
                  /forum/showthread.php/3553-this-is-the-thread/page6
                  /forum/showthread.php/3553-this-is-the-thread

                  It should be only this:

                  /forum/showthread.php/3553-this-is-the-thread

                  I really need to fix this problem, because having 18000 Duplicate meta descriptions is really a big problem.

                  Thanks.

                  Comment


                  • #10
                    Originally posted by polle View Post
                    Can anyone help with this ?

                    Having all that duplicates is really bad.

                    Instead of this:

                    /forum/archive/index.php/t-3553.html?
                    /forum/showthread.php/3553-this-is-the-thread/page2
                    /forum/showthread.php/3553-this-is-the-thread/page3
                    /forum/showthread.php/3553-this-is-the-thread/page4
                    /forum/showthread.php/3553-this-is-the-thread/page6
                    /forum/showthread.php/3553-this-is-the-thread

                    It should be only this:

                    /forum/showthread.php/3553-this-is-the-thread

                    I really need to fix this problem, because having 18000 Duplicate meta descriptions is really a big problem.

                    Thanks.
                    I am still looking into this.

                    I cant have 18000 Duplicate meta descriptions and 1500 Duplicate title tags because of this.

                    How to fix it ?

                    Thanks.

                    Comment


                    • #11
                      Really no one cares about this ?

                      I do, can someone please help ?

                      Thanks.

                      Comment


                      • #12
                        Still need a fix for this, I don't know how you see this, but 6 months waiting to solve a big problem is not good.

                        Comment


                        • #13
                          Anyone ?

                          Comment


                          • #14
                            If you believe this is a bug, please raise it in our Tracker above.
                            Vote for:

                            - *Admin Settable Paid Subscription Reminder Timeframe*
                            -
                            *PM - Add ability to reply to originator only*
                            - Add Admin ability to auto-subscribe users to specific channel(s)
                            - "Quick Route" Interface...

                            Comment


                            • #15
                              I just sent it here, I hope is the correct place and way to do it.

                              Now I have to wait ?
                              Or how does that work ?

                              I am looking for a solution before the next release "maybe" fixes this, As you can see i have been waiting 6 months now.

                              Thanks.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X