Announcement

Collapse
No announcement yet.

Default landing page.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Default landing page.

    I would like my default landing page to be my forum, not my cms. How do I make that happen? .htaccess does not work.

  • #2
    The index.php file goes to the main Home page by default. If you want it to go the the forum, then edit this section of that file:

    /**
    * Use the CMS as the default script:
    */

    require('content.php');


    /**
    * Use the forum as the default script:
    */

    // require('forum.php');

    To this:

    /**
    * Use the CMS as the default script:
    */

    // require('content.php');


    /**
    * Use the forum as the default script:
    */

    require('forum.php');
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hmmm... No joy

      I have this now...


      /**
      * Use the CMS as the default script:
      */

      // require('content.php');


      /**
      * Use the forum as the default script:
      */

      require('forum.php');

      But still nothing? check it .... www.plakplek.co.za

      Comment


      • #4
        That may be because you are using two different domains and directories:

        http://www.plakplek.co.za/

        http://plakplek.co.za/muur/forum.php

        What did you do exactly?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          omg buddy, I have no clue. I don't know when this would've happened? I am new to this. Yet I find myself digging around in **** i shouldn't. But... so I learn.

          I have no reason for it to be two different domains and directories? How do I rectify this?

          Comment


          • #6
            You probably did something to have the CMS in a different directory. What did you do exactly?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I dont know? Nothing out of the ordinary?

              The site has been functioning fine so far. Trevor Hannant helped my to make my cms my home page a while back? But that was weeks ago. I do not really know what to tell you, or where to start?

              Is your question what did I do to create two directories? Answer would be, I don't know. But... I would like if you could help me to fix this if it would be a problem?

              Comment


              • #8
                Post the contents of the index.php file that's in the root directory of your site here please.
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment


                • #9
                  <?php
                  require_once(dirname(__FILE__) . "/vb_dir.php");
                  chdir($vb_dir);
                  require_once($vb_dir . '/content.php');
                  ?>

                  Comment


                  • #10
                    I changed the content.php to forum.php. That seems to let me land on my forum page, but when I click home, I cant seem to reach my cms? It is running live like that now for a demo. www.plakplek.co.za

                    Comment


                    • #11
                      Worked For Me Steve, Many Thanks!

                      Originally posted by Steve Machol View Post
                      The index.php file goes to the main Home page by default. If you want it to go the the forum, then edit this section of that file:

                      /**
                      * Use the CMS as the default script:
                      */

                      require('content.php');


                      /**
                      * Use the forum as the default script:
                      */

                      // require('forum.php');

                      To this:

                      /**
                      * Use the CMS as the default script:
                      */

                      // require('content.php');


                      /**
                      * Use the forum as the default script:
                      */

                      require('forum.php');

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X