No announcement yet.

500 Internal Service Error - search.php

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] 500 Internal Service Error - search.php

    Recently installed the vBulletin Production Suite and I'm getting a "500 Internal Service Error" when I try to search for anything.

    Even clicking the "What's New" button incurs this error, because it involves the search function.

    I've reuploaded and installed everything several times now, just to make sure.

    I've contacted my host who seemed to think it was a problem with the search.php file. This is the error message:

    [Mon May 16 12:40:05 2011] [error] [client (ip)] Premature end of script headers: search.php, referer:
    [Mon May 16 12:40:05 2011] [error] [client (ip)] File does not exist: public_html/500.shtml, referer:
    I've had a look at this thread which mentioned a similar problem, but the apparent solution (replacing code in "vb/search/criteria.php") didn't work for me.

    I asked my host again, and he said the same error occured:

    [Mon May 16 13:33:25 2011] [error] [client (ip)] ] [notice] EACCELERATOR(15392): PHP crashed on opline 62 of method_exists() at /public_html/vb/search/criteria.php:844, referer:
    [Mon May 16 13:33:25 2011] [error] [client (ip)] , referer:
    [Mon May 16 13:33:25 2011] [error] [client (ip)] Premature end of script headers: search.php, referer:
    [Mon May 16 13:33:25 2011] [error] [client (ip)] File does not exist: /public_html/500.shtml, referer:
    I noticed this time "EACCELERATOR" was in this error message (possibly because i tried the previously mentioned solution, which didn't work), and in the previously mentioned thread, advice was given that eaccelerator was the problem.

    Can anyone help me out, please?

  • #2
    Woops, *Internal Server Error - not "Service Error"


    • #3
      500 Internal Sever Error for Search - Fixed

      Has taken all day, but my host has fixed the problem.

      I have created a php.ini file in (root directory) with the following contents:

      eaccelerator.enable 0
      eaccelerator.optimizer 0

      This has turned of eAccelerator for this domain and the search function appears to be working now.
      Seems like the problem was indeed eAccelerator. Hope this helps any others with this problem.


      • #4
        I just upgraded apache and php to 5.3.8 and this started happening on all my VB 4 forums. Was on php 5.2.17 before.

        Looks like this is a bug in VB's code.

        Turning eaccelerator off might work, but do you want to lose the performance?

        I found this solution:

        I'm willing to bet as more people upgrade php this starts popping up more and more. Should probably be fixed by VB.


        • #5
          @ aspen, Thanks for the link that was my issue. The forum/vb/search/criteria.php fix did the trick. Nice of my host to update Apache and not even bother to let me know. Again thanks, it fixed it perfectly.


          • #6
            I am experiencing this problem, unfortunately the link no longer works


            • #7
              Please start your own thread with full details of the problem.

              Server errors can have literally hundreds of different causes.....a three year old thread isn't going to help you much.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.4 Demo
              AdminAmmo - My Cloud Demo


              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.