Announcement

Collapse
No announcement yet.

Spammers are posting to my mod-only forum!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Spammers are posting to my mod-only forum!

    We have been getting users who succeed in registering as a mod, and then post spam to our mod-only forums.I'm aware of the thread re: stopping registration bots, but is there any info specifically addressing my problem? I don't munderstand how they are able to register AND give themselves mod status!? Does this happen to anyone else?
    Peter Caparelli

    I use vBulletin at www.LandOfMarbles.com:
    http://www.landofmarbles.com/phpbb/index.php

    and at www.MushroomVillage.com:
    http://www.mushroomvillage.com/shroomroom/

  • #2
    Note: This is not possible with the latest version of vB, if your permissions are set correctly, and you do not have add-ons installed.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      My copy of vB was installed by you guys, or one of your developers. Just about everything you say above in French to me. Is this possibly something I can pay you guys to do for me? I barely trust myself to do as you indicate above. I have no idea if I have the original non-image files - where would I find that?
      Peter Caparelli

      I use vBulletin at www.LandOfMarbles.com:
      http://www.landofmarbles.com/phpbb/index.php

      and at www.MushroomVillage.com:
      http://www.mushroomvillage.com/shroomroom/

      Comment


      • #4
        Use a support ticket !!
        environment: Centos 6.9, Apache v2.4.25, PHP 5.6.30/xCache, MariaDB 10.22 -- vB5 Connect Licensed

        AusPhotography - Australia's Premier Photographic Forum vB4.2.3
        Rick (site owner) and Kym (site tech) sharing this account

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X