Announcement

Collapse
No announcement yet.

Just upgraded from 3.8.7: Warning: fetch_template() calls should be replaced by th...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Just upgraded from 3.8.7: Warning: fetch_template() calls should be replaced by th...

    Hey, just upgraded from 3.8.7 and now have this error:

    Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: cyb_advancednewposts in [path]/includes/functions.php on line 4097

    Fatal error: Call to a member function hide_errors() on a non-object in /home/genrol/public_html/tehplayr.net/includes/class_bootstrap.php(414) : eval()'d code on line 137

    How can I fix it? Thanks! My site is http://tehplayr.net/. http://tehplayr.net/admincp/ works until you login, then I get the same error.

    Thanks!

  • #2
    The whole upgrade appeared to go swimmingly, it directed me to my Admin CP and then this.

    Comment


    • #3
      This is from a modification. You'll need to disable all modifications and the error will go away.

      You'll then need to obtain vb4 versions of any modifications you wish to continue to use. Any 3.x modification that uses templates will not work on vB4.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.6.0 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        How can I disable modifications with no access to the administrator panel?

        Comment


        • #5
          Got it! For anyone here with the same problem add define('DISABLE_HOOKS', true); directly after <?php in your config file.

          Comment


          • #6
            ^just wanted to thank you for the proper coding to disable the plugin system.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X