Announcement

Collapse
No announcement yet.

Anyone else's scheduled tasks not running at the correct time?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lynne
    replied
    If your server time is correct and your default time zone in your options is correct and your own setting in the settings on your forum is correct, then I don't understand how it can all be off by 12 hours.

    Leave a comment:


  • vinzphua
    replied
    Yep. I've checked.

    Leave a comment:


  • Lynne
    replied
    Are you 100% positive the server time is set correctly?

    Leave a comment:


  • vinzphua
    replied
    Originally posted by Zachery View Post
    Actually, I think tasks all run on GMT0 for some reason. Could just be cobwebs in the vBulletin section of my brain though.
    Even so, it should still run at the set time in that time zone.

    Mine doesn't do that. If I set 4 under the 'h' column for task A, it runs and is logged at 16:00 in my time zone, which is 20:00 the previous day in GMT+0. (This is confirmed as my Daily Digest Task is set at 4am, but I receive the email at 16:00 at my timezone. It is logged as 16:00 as well.)

    Leave a comment:


  • Lynne
    replied
    All of my tasks run at the server time which also happens to be the default time I have set in the admincp.

    Leave a comment:


  • Zachery
    replied
    Actually, I think tasks all run on GMT0 for some reason. Could just be cobwebs in the vBulletin section of my brain though.

    Leave a comment:


  • vinzphua
    replied
    Yes. Server time is also GMT +8.

    Anyway, if I set a task to run at 5 am, it should run at 5am server time, or 5am Admin CP time zone consistently. Not some other time.

    Leave a comment:


  • Lynne
    replied
    Then the scheduled tasks should show up in that time zone. Have you checked your server time? vBulletin gets it's time from the server.

    Leave a comment:


  • vinzphua
    replied
    Default Time Zone Offset is GMT +8 for Singapore.

    My own profile's Time Zone is the same.

    Leave a comment:


  • Lynne
    replied
    What do you have set in AdminCP > Settings > Options > date and time options > default time zone offset? And, what do you have set in your own profile for the default time zone offset?

    Leave a comment:


  • Anyone else's scheduled tasks not running at the correct time?

    Hi,

    I have made a bug report in JIRA, but I'm curious if any one else have noticed that their scheduled tasks are not running as scheduled.

    In my case, the tasks are executed 12 hours after the set time. For example, if I set the time at 5AM (i.e. 5 under the 'h' column), the Scheduled Tasks Manager actually shows 'Next Run' as 17.00. My Scheduled Tasks logs shows it as executed at 17.00 as well.

    I've set the Activation Reminder Email task to execute at 04:30, but Next Run shows 16:30, logged as 16:30 and I've checked and found Activation Reminder emails sent out at 16:30.

    It seems unrelated to Time Zone, as my server Time Zone is GMT +8, vBulletin Admin CP 'Default Time Zone Offset' is set at GMT +8.

    When I was on a different server years ago, while on vB 3.8.x, I discovered this problem. Back then the mathematics showed that the tasks ran at my 'Default Time Zone Offset' + server time zone difference from mine.

    If you have similar problems, it'll be good to post your time zone and scheduled tasks settings in my bug report so that the vB team has more info to work with and figure out what's wrong.

Related Topics

Collapse

  • BTMike
    Task Manager
    by BTMike
    After migrating from cloud to stand alone, there is something going on with the Scheduled Task Manager I am not understanding.

    It seems that no matter what time I set task for my admin panel...
    Thu 19 Nov '20, 7:05pm
Working...
X