Announcement

Collapse
No announcement yet.

manage attachments button disapeared in the Additional Options after upgrade to 4.1.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] manage attachments button disapeared in the Additional Options after upgrade to 4.1.3

    Hello,

    on my forums the manage attachments to add attachments button diapeared after upgrade from 4.1.1 to 4.1.3,
    all the forum permissions are set correctly, attachments are enabled, but the button to add attachments in "Additional Options" is gone.

  • #2
    Do you have any modified templates? They show as a orange color.

    Comment


    • #3
      Originally posted by Andy View Post
      Do you have any modified templates? They show as a orange color.
      i'm using a different template from vb 4.0 Default Style,
      but also in the default style with all reverted templates this option is missing,
      here are the screenshots,
      and the forum permissions screenshot for administrator.
      Attached Files

      Comment


      • #4
        Try turning off the Asset Manager so it defaults to the simple attachment manager and verify you are able to upload with it.

        Admin CP -> Settings -> Options -> Asset Manager Enable -> No

        Comment


        • #5
          Originally posted by Andy View Post
          Try turning off the Asset Manager so it defaults to the simple attachment manager and verify you are able to upload with it.

          Admin CP -> Settings -> Options -> Asset Manager Enable -> No
          thanks for reply,
          Asset Manager Enable was already set "No", i have also tried to change this option and put it back to "No" with not luck.

          looks like im the only one with this problem, i will try to reupload the vbulletin 4.1.3.

          Comment


          • #6
            Do you have any products or plugins?

            Comment


            • #7
              hi,
              yes i have some, and if i disable all products the attachment button is still missing,
              also if i upload vbulleting script from scratch and connect it to the old database the manage attachments button is missing too,
              looks like there is a bug in database or in templates.

              in the posting permissions i see: You may not post attachments, so the problem seems to be in permissions, but i havent changed any permissions for the forums and usergroups.
              Last edited by GumSlone; Fri 8th Apr '11, 11:44am.

              Comment


              • #8
                Originally posted by GumSlone View Post
                hi,
                yes i have some, and if i disable all products the attachment button is still missing,
                also if i upload vbulleting script from scratch and connect it to the old database the manage attachments button is missing too,
                looks like there is a bug in database or in templates.

                in the posting permissions i see: You may not post attachments, so the problem seems to be in permissions, but i havent changed any permissions for the forums and usergroups.
                There is one other place that can disable attachments.

                Admin CP -> Attachments -> Attachment Permissions

                Are any of the extension types (user groups) showing in red?

                Comment


                • #9
                  No, all of them are blue,
                  see the screenshot, all other extensions and usergroups have the same color.
                  Attached Files

                  Comment


                  • #10
                    Does your usergroup(s) have permission to upload attachments?

                    Comment


                    • #11
                      Originally posted by Zachery View Post
                      Does your usergroup(s) have permission to upload attachments?
                      Post #7 indicates he has checked the usergroup permissions. Perhaps he overlooked the correct usergroup?

                      Comment


                      • #12
                        I am not sure what screen that is, but its not the actual AdminCP > Usergroups > Usergroup Manager > Edit Usergroup permissions screen.

                        Comment


                        • #13
                          Originally posted by Zachery View Post
                          I am not sure what screen that is...
                          Post #7 doesn't have an attachment, so I'm not sure what you are referring to.

                          Comment


                          • #14
                            Originally posted by Zachery View Post
                            Does your usergroup(s) have permission to upload attachments?
                            hello,

                            well actually i havent changed any permissions those are the same like they were before the upgrade from 4.1.1 to 4.1.3,
                            with 4.1.1 users could upload attachents to the topics/posts and after upgrate the "manage attachments" button is gone for all user groups,
                            in Attachment Permissions all the user group settings are default, admin / moderator / super moderator / user can use all the extensions,
                            for the forums i also use the dafault user group permissions,

                            here are the screenshots for forum permissions, usergroup administrator,
                            and AdminCP > Usergroups > Usergroup Manager > Edit Usergroup screen for administrator user group, the same attachement setting is set for other default user groups like user/moderator/super moderator.
                            Attached Files
                            Last edited by GumSlone; Sat 9th Apr '11, 7:00pm.

                            Comment


                            • #15
                              is there a global variable with which i can enable attachments for all user groups in config.php similar to
                              PHP Code:
                              define('DISABLE_HOOKS'true); 
                              (which overwrites database settings and disables all plugins),

                              i need something similar for attachments to enable them in all forums for all user groups.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X