Announcement

Collapse
No announcement yet.

MySQL Error Unknown column 'fd.thumbnail_filesize' in 'field list'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] MySQL Error Unknown column 'fd.thumbnail_filesize' in 'field list'

    hi all

    i got this erorr

    PHP Code:
    Database error in vBulletin 4.1.2:

    Invalid SQL:

                    
    SELECT
                        fd
    .thumbnail_datelinefd.filesize, IF(fd.thumbnail_filesize 010) AS hasthumbnailfd.thumbnail_filesize,
                        
    a.datelinea.statea.attachmentida.countera.contentida.filenamea.userida.settingsa.displayorder,
                        
    at.contenttypes
                    FROM attachment 
    AS a
                    INNER JOIN filedata 
    AS fd ON (fd.filedataid a.filedataid)
                    
    LEFT JOIN attachmenttype AS at ON (at.extension fd.extension)
                    
    WHERE
                        a
    .contentid IN (81195,81203,81286,81287,81289,81290,82837)
                            AND
                        
    a.contenttypeid 1
                
    ORDER BY a
    .contentida.displayorder;

    MySQL Error   Unknown column 'fd.thumbnail_filesize' in 'field list'
    Error Number  1054 
    any help plzzzzz??

  • #2
    i stoped all addons via config.php and nothing change

    Comment


    • #3
      When did you get the error? There is a massive SQL Injection problem hitting the net..


      http://blog.trendmicro.com/lizamoon-...till-on-going/

      http://www.betanews.com/article/Mass...tes/1301688515

      http://www.google.com/search?aq=f&so...466ef0eba5f8fb

      My site went down 2 days ago.. VBULLETIN was hit and crashed hard due to this..

      Comment


      • #4
        Originally posted by dfcrone View Post
        When did you get the error? There is a massive SQL Injection problem hitting the net..


        http://blog.trendmicro.com/lizamoon-...till-on-going/

        http://www.betanews.com/article/Mass...tes/1301688515

        http://www.google.com/search?aq=f&so...466ef0eba5f8fb

        My site went down 2 days ago.. VBULLETIN was hit and crashed hard due to this..
        thank you bro

        but i hav it ok ysterday but today i got this

        do you have an edea how to fix it or just waiting ??

        Comment


        • #5
          Just waiting now.. I put in a support ticket a few minutes ago, and amazingly, they are backed up due to a high amount of support traffic. (I can imagine why!)

          What version were you running? I was using 3.x but am upgrading to 4.12 tonight to see if this fixes it. I am also going to delete the last 2 weeks of messages and new users.

          This sucks but I need to protect our site.

          Let me know what happens..

          Peace..

          D/C

          Comment


          • #6
            What version were you running? I was using 3.x but am upgrading to 4.12 tonight to see if this fixes it. I am also going to delete the last 2 weeks of messages and new users.

            This sucks but I need to protect our site.

            Let me know what happens..
            do you have same problem ??

            i have vb v. 4.1.2 but now i updated to 4.1.3 beta and nothing change

            i closed my forum now and witing will see and looking suliton and fix

            i have buckup i dont worry but need to know what is this

            thnk you for help bro you are my man

            Comment


            • #7
              This has nothing to do with that non-vB exploit, so please ignore dfcrone.

              Invalid SQL errors are almost always related to modified code.

              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

              Admin CP -> Plugins & Products -> Manage Products -> Disable

              Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

              Admin CP -> Plugins & Products -> Plugin Manager

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

              Do you have the same problem?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X