Announcement

Collapse
No announcement yet.

Video BBCode: How to add new video source

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Video BBCode: How to add new video source

    I have not found a description of how to add a new video source to the video bbcode.

    There is a file includes/xml/bbcode_video_vbulletin.xml. I assume I have to add the code her? But what about the table bbcode_video?

    What's the use of the element/column regex_scrape?

    There is also a template bbcode_video.

    I tried to add the code to the .xml and to the template. It doesn't seem like the new code gets copied to the table.

    But I read another post where somebody copied it also into the table and it still did not work.

    Does anybody know how to do this?

    Thanks!
    noox, Mountainbike Downhill Board

  • #2
    AdminCP > custom BB codes. There is also a comprehensive video BB code mod at vbulletin.org.

    Comment


    • #3
      Really?

      There is already the the video-bbcode. I do not want a new bb-code. I want the video-bbcode to handle additional source. Not only youtube, vimeo, facebook, ... but also some video sites which are very common at my forum.

      Ah, I thought that AME is not available for 4.x. But I just found AME3 for 4.0.0 - but it has not been updated since Januray 17th 2010

      It would be really great if vBulletin developers post a how-to for adding new video sources to the existing video-bbcode.
      noox, Mountainbike Downhill Board

      Comment


      • #4
        Please feel free to make a 'New Feature' request here:

        http://tracker.vbulletin.com/secure/IssueNavigator.jspa

        We take all suggestions into account when determining the feature set for new versions but unfortunately we cannot confirm whether a particular feature will be included in a version.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thanks! I will do! Thought that this could already be accomblished without code modifications. But a user interface would be a bonus.
          noox, Mountainbike Downhill Board

          Comment


          • #6
            After adding code tot he xml file, you need to enable debug mode and rebuild the video bbcode in the admincp.

            Comment


            • #7
              Thanks a lot! Finally I got it running. I didn't know that with debug mode and rebuilding bbcode. So I added the code manually to the table. Initially I had typos so it didn't work. And as I found some unanswered similar questions (already older) I thought I try it again with a new thread.

              Here is the feature request: http://tracker.vbulletin.com/browse/VBIV-11657

              For others:
              - add provider to includes/xml/bbcode_video_vbulletin.xml
              - enable debug mode
              - rebuild video bbcode
              - add code to bbcode_video template (search for "youtube" in templates)
              noox, Mountainbike Downhill Board

              Comment


              • #8
                ok i'm trying to add the youtu.be addresses to my test site and have ended up on this post here giving the most useful info so far that has helped me in trying to get Zachary's post @ http://tracker.vbulletin.com/browse/VBIV-11734 to work. however i still cannot get these damn addresses to work!
                so can someone, preferably zachary or noox, please help out.

                i have added zacherys code to the bolded bit below
                i enabled debug mode
                i ran post cache (no other idea on how to rebuild bbcode)
                turned off debug

                youtu.be addresses still do not work!

                can someone please help!


                Originally posted by noox View Post

                For others:
                - add provider to includes/xml/bbcode_video_vbulletin.xml
                - enable debug mode
                - rebuild video bbcode
                - add code to bbcode_video template (search for "youtube" in templates)
                licence 4.1.2 Suite
                feeltheword.net/forum

                Comment


                • #9
                  In debug mode, there is a tab called rebuild in the admincp. there you can rebuild the video bbcode.

                  Comment


                  • #10
                    Hi all,

                    I'm trying to add new video source from http://ctc.ru website.

                    Code for share is
                    HTML Code:
                    <object width="704" height="528"><param name="data" value="http://videomore.ru/player.swf"><param name="allowFullScreen" value="true"><param name="allowScriptAccess" value="always"><param name="flashvars" value="config=http://videomore.ru/video/tracks/26933.xml"><embed src="http://videomore.ru/player.swf" type="application/x-shockwave-flash" wmode="transparent" width="704" height="528" allowFullScreen="true" allowScriptAccess="always" flashvars="config=http://videomore.ru/video/tracks/26933.xml"></embed></object>
                    I do following actions:
                    1. Added new provider to includes/xml/bbcode_video_vbulletin.xml
                    PHP Code:
                      <provider tagoption="STS">    <title>STS</title>    <url>http://ctc.ru/</url>    <regex_url></regex_url>    <regex_scrape><![CDATA[http:\/\/videomore\.ru\.com\/video\/tracks\/([0-9\-]+)\.xml]]></regex_scrape>    <embed>      <![CDATA[      <object width="704" height="528"><param name="data" value="http://videomore.ru/player.swf"><param name="allowFullScreen" value="true"><param name="allowScriptAccess" value="always"><param name="flashvars" value="config=http://videomore.ru/video/tracks/{vb:raw code}.xml"><embed src="http://videomore.ru/player.swf" type="application/x-shockwave-flash" wmode="transparent" width="704" height="528" allowFullScreen="true" allowScriptAccess="always" flashvars="config=http://videomore.ru/video/tracks/{vb:raw code}.xml"></embed></object>      ]]>    </embed>  </provider> 
                    2. Enabled debug mode

                    3. R
                    ebuilt video bbcode

                    4. Modified
                    bbcode_video template
                    Code:
                    <vb:elseif condition="$provider == 'STS'" /> 
                    <object width="704" height="528">
                    <param name="data" value="http://videomore.ru/player.swf"><param name="allowFullScreen" value="true"><param name="allowScriptAccess" value="always"><param name="flashvars" value="config=http://videomore.ru/video/tracks/{vb:raw code}.xml">
                    <embed src="http://videomore.ru/player.swf" type="application/x-shockwave-flash" wmode="transparent" width="704" height="528" allowFullScreen="true" allowScriptAccess="always" flashvars="config=http://videomore.ru/video/tracks/{vb:raw code}.xml"></embed></object>
                    But new code was not applied. Could you advice please, what is wrong?

                    Comment


                    • #11
                      I was able to process link http://videomore.ru/video/tracks/26933 instead of whole share code. As result I got code:
                      PHP Code:
                      [video=STS;27141]http://videomore.ru/video/tracks/27141[/video] 
                      But player didn't apper in message although I modified bbcode_video template. What is wrong? any advices.

                      Comment


                      • #12
                        Originally posted by SuhovDE View Post
                        I was able to process link http://videomore.ru/video/tracks/26933 instead of whole share code. As result I got code:
                        PHP Code:
                        [video=STS;27141]http://videomore.ru/video/tracks/27141[/video] 
                        But player didn't apper in message although I modified bbcode_video template. What is wrong? any advices.
                        You haven't written PHP code to support this code and tell the system what to do with it. Adding new video sources to the [video] bbcode isn't supported at this time.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                        vBulletin 5 Documentation - Updated every Friday. Report issues here.
                        vBulletin 5 API - Full / Mobile
                        I am not currently available for vB Messenger Chats.

                        Comment


                        • #13
                          Originally posted by Wayne Luke View Post
                          You haven't written PHP code to support this code and tell the system what to do with it. Adding new video sources to the [video] bbcode isn't supported at this time.
                          Wayne Luke, could you tell me please, where I can see example and where I should place this code?

                          Comment


                          • #14
                            You would have to see if anyone has wrote anything up at www.vbulletin.org. Like I said, we do not support adding new video providers.
                            Translations provided by Google.

                            Wayne Luke
                            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                            vBulletin 5 Documentation - Updated every Friday. Report issues here.
                            vBulletin 5 API - Full / Mobile
                            I am not currently available for vB Messenger Chats.

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X