Announcement

Collapse
No announcement yet.

Auto login doesn't work sometimes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Auto login doesn't work sometimes

    Since I upgraded my forum from 3.8.6 to 4.1.1, the auto login doesn't word correctly.

    When I load the forum homepage from the favorites, or type directly to the browser, it look like I'm not logged in, but after clicking to any topic, forum, or just refresh, I'm logged in.

    I tested it on different computers and browsers, some of them is working, some not, but there is no rule.

    Whan can I do to make it work correct?

  • #2
    Originally posted by Evoklub View Post
    Since I upgraded my forum from 3.8.6 to 4.1.1, the auto login doesn't word correctly.

    When I load the forum homepage from the favorites, or type directly to the browser, it look like I'm not logged in, but after clicking to any topic, forum, or just refresh, I'm logged in.

    I tested it on different computers and browsers, some of them is working, some not, but there is no rule.

    Whan can I do to make it work correct?
    Most likely your browser is fetching a cached copy where you aren't logged in.

    When this happens, try refreshing the page (F5, or the refresh button). Are you logged in then?

    If so, clear your browser's cache (temporary internet files) and cookies. If you tell us which browser we can post instructions if you're not sure.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      When I refresh the page (F5), I'm still not logged in. But if I click to any topic, or even to "What's new", I'm logged in.

      Comment


      • #4
        What is the url you go to where you['re not logged in? vs the url when you are logged in.

        Comment


        • #5
          Zachery, good idea:

          http://forum.evoklub.hu - NOT logged in
          http://evoklub.hu/forum - logged in

          What's the problem?

          (On same computer, with another account with IE it works, with my account on Firefox doesn't.)

          Comment


          • #6
            Originally posted by Evoklub View Post
            Zachery, good idea:

            http://forum.evoklub.hu - NOT logged in
            http://evoklub.hu/forum - logged in

            What's the problem?

            (On same computer, with another account with IE it works, with my account on Firefox doesn't.)
            Your site is using two different URL formats. The cookies are URL-specific so if you log in at the first URL, you are then not logged in at the second.

            You need to standardise your links so that everything points to one or the other, not both.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.4 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Thanks, and how can I do it?

              Comment


              • #8
                For starters, book mark the right url. Then try google for htaccess redirect.

                Code:
                RewriteEngine On
                RewriteCond %{HTTP_HOST} !^www\.
                RewriteCond %{HTTP_HOST} !^forum\.
                RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

                Comment


                • #9
                  Thank you very much!

                  Comment


                  • #10
                    I've found the solution:

                    Settings - Options - Cookies and HTTP Header Options

                    Cookie Domain - Custon Settings, and there: .forumname.com instead of forumname.com

                    Not it works perfectly.

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X