Announcement

Collapse
No announcement yet.

Users Post Being Moderated

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Users Post Being Moderated

    Hi,

    I have a few users who's posts keep being moderated in one forum. Nobody else is being moderated in that forum. The users who are being moderated can post in other forums without moderation.

    Anyone know why a couple users would be having posts moderated in a forum? They are all in the same usergroup.

    Thanks

  • #2
    Check the forum permissions for that usergroup and make sure they are not set under moderation queue.
    while(true){
    if(
    $someone->needsHelp() && $i->canHelp()) $post->help();
    if(
    $i->findBug()) $post->bug();
    }

    Comment


    • #3
      Where would I find moderation queue?

      I checked usergroup permissions and everything looks good to go. These users are in the registered usergroup with about 500 other people if that matters? Everyone else can post.

      Comment


      • #4
        Check out the manual -> Managing Forum Permissions
        Make sure that the option Always Moderate This Group's Post is set to No
        while(true){
        if(
        $someone->needsHelp() && $i->canHelp()) $post->help();
        if(
        $i->findBug()) $post->bug();
        }

        Comment


        • #5
          Forum permissions - post / thread permissions - Follow Forum Moderation Rules - Yes

          Just out of curiousity, if i set the group to be moderated wouldn't the entire group be moderated not just a couple users?

          Comment


          • #6
            Originally posted by Eruss View Post
            Just out of curiousity, if i set the group to be moderated wouldn't the entire group be moderated not just a couple users?
            That's true, as this is a usergroup settings. Make sure that those users are not set in multiple usergroups.
            while(true){
            if(
            $someone->needsHelp() && $i->canHelp()) $post->help();
            if(
            $i->findBug()) $post->bug();
            }

            Comment


            • #7
              They are set in a primary group of "registered users" and two additional usergroups.

              The one additional usergroup over half of my members are in with no problems.

              The other additional usergroup, I checked the permissions on and they all look good.

              I'm wondering if I should delete there account and start a new one?

              Comment


              • #8
                Make sure you check the forum permission for that usergroup, not the usergroup permission.
                I guess the issue is somewhere in the settings, but I can't know for sure without taking a look at your acp.
                while(true){
                if(
                $someone->needsHelp() && $i->canHelp()) $post->help();
                if(
                $i->findBug()) $post->bug();
                }

                Comment


                • #9
                  Shouldn't the permissions be taken from the primary usergroup? I've checked the others, I'll check them again.

                  Thanks

                  Comment


                  • #10
                    You are right, the primary usergroup should overwrite the others.
                    while(true){
                    if(
                    $someone->needsHelp() && $i->canHelp()) $post->help();
                    if(
                    $i->findBug()) $post->bug();
                    }

                    Comment


                    • #11
                      Hi, I am still having an issue with this. The weird thing is the moderation is intermittent. Sometimes you can post without moderation and sometimes you can.

                      Comment


                      • #12
                        A yes always overrides a no, regardless of which usergroup were talking about.

                        Comment


                        • #13
                          Originally posted by Zachery View Post
                          A yes always overrides a no, regardless of which usergroup were talking about.
                          My problem is, one day I can make a post in a forum, the next day my post needs to be moderated in the same forum.

                          It would seem to me that would rule out a permissions problem. As far as I can see there's no option for me to be able to post on Monday's but be moderated on Thursday's!

                          Comment


                          • #14
                            i am hving similar issues... but, i think it is more of the content of what is being posted by the users...are they trying to post a link? or a URL?

                            l think my issues are related to these 'attachments'.. somehow i think it is confusing (to me), what an attachmetn is? is it everything that isnt text? is it a url? is it an image if the image is a direct link?

                            anyways, Im still waiting for my answers and was browsing to see if others have something similar and yours is very similar to mine...


                            good luck


                            bill

                            Comment


                            • #15
                              Here are all the settings that would affect this.

                              1. Check the overall Usergroup settings for the relevant usergroups and make sure moderation is turned off:

                              Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup -> Follow Forum Moderation Rules -> Yes

                              2. Check the individual forum settings to make sure moderation is turned off:

                              Admin CP -> Forums & Moderators -> Forum Manager -> Edit Forum -> Moderate Posts and Moderate Threads -> No

                              3. Check ALL the usergroup permissions for that forum (Forum Permissions). One of the usergroups they are in has Follow Forum Moderation Rules set to 'No'. This needs to be set to 'Yes'.

                              Admin CP -> Forums & Moderators -> Forum Permissions -> Edit (appropriate forums and usergroups) -> Follow Forum Moderation Rules

                              4. Make sure the Primary usergroup has 'Allow Users to have Member Groups ' set to 'Yes'. Otherwise secondary permissions are not considered.

                              5. If you have the Anti-Spam Service setting turned on, it could be automatically moderating some posts:

                              Admin CP -> Settings -> Options -> Spam Management -> Anti-Spam Service

                              If you have Akismet or Typepad chosen then that is what is moderating these posts.

                              Otherwise if these permissions are all set correctly and you still have this problem, then it is from a modification you made.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X