Announcement

Collapse
No announcement yet.

Error when installing plugins.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error when installing plugins.

    Hello,
    I've setup a brand new forum and just downloaded this as the first plugin/mod on the forum.
    When installing/uploading the plugin xml file I get the following error.

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/usr/home/tmp/php8rXcz1) is not within the allowed path(s): (/home/jappleton/:/tmp:/var/tmp:/usr/local/lib/php/) in [path]/includes/adminfunctions.php on line 2449

    No idea what's wrong or what it means. Your help would be greatly appreciated.

    Thanks.

  • #2
    Answered you here.

    It's a setting in php that needs to be adjusted.
    To be updated...

    Comment


    • #3
      You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory.

      Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

      Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes

      Also the php.ini setting for 'upload_tmp_dir' may be empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.
      Vote for:

      - *Admin Settable Paid Subscription Reminder Timeframe*
      -
      *PM - Add ability to reply to originator only*
      - Add Admin ability to auto-subscribe users to specific channel(s)
      - Highlight the correct navigation tab when you are on a custom page
      - "Quick Route" Interface...
      - Allow to use custom icons for individual forums

      Comment


      • #4
        By the way, if you follow those directions, that director should be set to: /home/jappleton/tmp
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X