Announcement

Collapse
No announcement yet.

Database error message-Too many connections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Database error message-Too many connections

    Can someone give me some ideas please?
    I have just had five database error messages in a row saying the following:
    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections /home/sites/worldofglasscraft.com/public_html/includes/class_core.php on line 312

    MySQL Error :
    Error Number :
    Request Date : Tuesday, March 8th 2011 @ 03:53:53 PM
    Error Date : Tuesday, March 8th 2011 @ 03:53:53 PM
    Script :
    Referrer :

    IP Address :

    Username :
    Classname : vB_Database
    MySQL Version :


    The script and referrer addresses are both my forum URL and the ISP addresses are all different but all come back in google as being spammers addresses.
    Is this just a connection error record or is it something more sinister that I should be taking action to combat please?
    Thanks in advance for any advice.
    Regards
    Tony
    www.worldofglasscraft.com

  • #2
    The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off by adding this to your config.php:
    PHP Code:
    $config['MasterServer']['usepconnect'] = 0
    But, if you still have the problem you will have to talk to your host about raising that limit. Also, see this Common MySQL Error Messages

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      Thanks Lynne,
      Oddly I have had 111 members online at one time with no problems but this time I had 5 spammers.

      I will have to contact support as I lost my "do_not_upload" folder following a hard disc getting fried .
      Regards
      Tony
      www.worldofglasscraft.com

      Comment


      • #4
        Just download the software from the members area again and the do_not_upload directory will be in there.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools &lt;- awesome site for html/css help

        Comment


        • #5
          If ur forum gets too big you won't be able to run it on a shared server. They have really small connection limits.

          Comment


          • #6
            Yes. That error means that there are too many connections to that same shared account so the error comes up.

            Comment


            • #7
              Originally posted by riceboi1230 View Post
              Yes. That error means that there are too many connections to that same shared account so the error comes up.
              The error email now states:
              Too many connections /...../..../......./...../includes/class_core.php on line 314
              Its always the same three ISP's , One russian federation and two on a spam list.

              If I add these ISP's to my banned user list might it sort it out? I will have to have a word with my server company as stated.
              Regards
              Tony
              www.worldofglasscraft.com

              Comment


              • #8
                To many connections is to many connections. Its the number of users accessing your site, or the entire server at one time. Short of adjusting the mysql settings, or getting your webhost to do it. Nothing will fix this.

                Comment


                • #9
                  If spam IP addresses are connecting to your site in large numbers then its likely that spam bots are trying to register many times per second. If your registration process effectively blocks spam bots, then it can happen that your site will get hammered from the repeated attempts. This can be countered with scripts like bad behavior.

                  If its not related to spam bots, then its simply a case of setting your max_connections to a higher number.
                  I buy 420 forums

                  Comment


                  • #10
                    Cheers dude, I will have a word with my host. Its definately spam bots from Russia though.
                    Regards
                    Tony
                    www.worldofglasscraft.com

                    Comment


                    • #11
                      In that case, keep an eye on www.vbulletin.org. I have invited the developer of bad behavior ( http://bad-behavior.ioerror.us/ ) to code a vbulletin addon and he is very enthusiastic about it. So hopefully it will lead to an addon to stop these bots in their tracks.
                      I buy 420 forums

                      Comment


                      • #12
                        Well, I had a word with my ISP and they tell me that the maximun number of connectioons for all accounts is set to 25.
                        I asked how this can be when I have had 118 visitors online at one time with no problems but they couldn't answer.
                        As of this morning 12/04/11 between 10:00 and 12:26 I have received 3321 datbase error notifications of timeout generated by vbulletin and sent to me via email .

                        Oddly, ALL 3321 have been timeout connections to my calender, which is the default calander.

                        Could it be a case that my ISP (Heart) is the wrong ISP for me?
                        Regards
                        Tony
                        www.worldofglasscraft.com

                        Comment


                        • #13
                          I'm getting periodic problems with this error and have had a series of online chats with the technical support guys at Hostgator who start off telling me that I need to upgrade to a better package. Seeing as I've never had more than 9 concurrent online users (my forum is still under development), I refused to accept this.

                          Then I found one of THEIR technical documents that reckoned a site with 500 currently active members will rarely hit the limit that Hostgator sets of 25 MySql connections as the connections are taken and released very quickly.

                          I told HostGator that I'd turned persistent connection off. They said it was probably an error in the vBulletin software. But it's a completely vanilla site, no script changes/mods whatsoever.

                          The problem goes away for a while, then returnsójust had seven errors in the last hour.

                          Tim
                          www.morocco-knowledgebase.net

                          Comment


                          • #14
                            In the future please post in your OWN thread, and include any error messages.

                            Comment


                            • #15
                              I'm experiencing the same thing. Makes no sense.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X