Announcement

Collapse
No announcement yet.

vB 4.1.2 Mobile Style not working for me

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] vB 4.1.2 Mobile Style not working for me

    I upgraded a testing site from vB 4.0.8 to 4.1.2, then installed the new Mobile style per instructions I found here on the forum. I had previously been using the Lightweight Mobile style and the Mobile Detection mod from vbulletin.org with success on vB 4.0.8.

    When I access the site with the new Mobile style assigned as the default (so it will appear in a standard browser) I find that none of my top level category links work. They appear on the homepage and appear as though there should be links because of the pointer change, but when I look at the browser footer it doesn't show a target link for any of the categories like it does for any other clickable item on the page. I have already tried the define('DISABLE_HOOKS', true); in the config.php file to disable all the mods I have installed.

    The Lightweight Mobile style and Mobile Detection mod both worked with my assortment of mods, including the sub-forum manager I use. The new Mobile style doesn't appear to work at all for me.

    I think my next step should be to create a new test site with a fresh install of 4.1.2 and see how things work there. Are there any other suggestions I should consider?
    Just getting started... Your patience is appreciated.

  • #2
    Firstly you need to use a webkit browser to browse mobile style (Safari or Google Chrome).
    And if you're talking about forum categories, the answer is yes. You can see a hand mouse cursor but it doesn't link you to forum category page. And if you use mobile browser you will find that they're not clickable/touchable.

    For forum rows, if you want to see the links in browser's status bar, you need to mouse over forum's title (in bold font).

    But if you also find that the layout of mobile style is not as expected, please fire a bug. Thank you.

    Comment


    • #3
      Well, Safari or Chrome aren't available on my Blackberry either so that seems a bit limiting. Are you saying this mobile style is very limited in which browsers can properly display it?

      Next, it seems like you are saying the mobile style does not support forum categories. Are you suggesting I completely redesign my site to remove forum categories, or choose to not use the mobile style? I guess I don't see the viability of the mobile style if it can't deal with forum categories in a usable manner. If I enable "act as forum" will the mobile style properly display the sub-forums? Then I have to deal with the new post button that makes no sense...

      Is there some documentation as to what the intent of the mobile style is, what does and what does not work, etc.? I don't want to file a bug report on things I consider to be problems that you have apparently made design choices to ignore or remove. If I know what your intent is I can quickly determine if I am wasting my time with the mobile style and should move on, or whether I need to invest more time to make it workable for me.
      Just getting started... Your patience is appreciated.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X