Announcement

Collapse
No announcement yet.

attachments problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] attachments problem

    hey there,
    I've got a problem with attachments system. I just can't add a new attachment via attachments manager.
    I was trying to add a new one, clicked "manager" during writing a new post then I chosen "upload files from your computer". I chosen a file "image.gif" to upload, clicked 'upload' and... I just saw a red interjection and no new file wasn't added.
    So I moved attachments from database to files' system (I made attachments' dir to CHMOD 777) but STILL the same problem - I can't upload files as attachments.

    Any ideas?

  • #2
    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post

      Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled

      Mine is set to NO, is there a benefit to moving mne to yes please Steve and if so what will it be please?
      Regards
      Tony
      www.worldofglasscraft.com

      Comment


      • #4
        If you want us to troubleshoot this, then set it to yes and provide the link to your forums.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          ok I have set it to yes.
          my forum is www.worldofglasscraft.com
          Regards
          Tony
          www.worldofglasscraft.com

          Comment


          • #6
            The only thing I see that could cause this is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

            You may need to reboot the server after making this change.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thanks Steve, I have switched that off now.
              Can you tell me where abouts using &do=phpinfo you were able to see the info about my upload_tmp_dir please?

              I take it that the path you advise would read something like www/xxx.com/chosenfolder . Where the folder is outside public_html please?
              Regards
              Tony
              www.worldofglasscraft.com

              Comment


              • #8
                If you view your phpinfo and search for 'upload_tmp_dir', you'll see it there.

                Regarding the path, yes I'd place this above the web root
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X