Announcement

Collapse
No announcement yet.

Fatal error: Class 'vB_Cache_Db' not found in...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Fatal error: Class 'vB_Cache_Db' not found in...

    Fatal error: Class 'vB_Cache_Db' not found in /home/dislex/westtexasforums.com/theforums/vb/cache.php on line 128




    I can access the forum's main page, but as soon as I try to open a thread, I get that same error. Each and every time. Each and every thread.



    My Site: www.WestTexasForums.com

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Eek. I forgot to add something important.

      Before this happened, I tried to upgrade to the latest version. I guess I did something wrong, as it did not work. I then rolled my site back a couple of hours. That is when I started getting the above error.

      Should I follow the steps mentioned above, or should I follow them, BUT with the NEW vB files?

      Comment


      • #4
        How did you roll back exactly?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          How did you roll back exactly?
          Well, I am with DreamHost and unfortunately there is no way to go back to a certain time. The option I used could have went back anywhere from 1 hour to 1 day. I click on that single option and the hosts robot picks anywhere in that 1h-1d rang. In other words, I really have no idea how far back I went.

          Also, there is a reason I need to fix this error as opposed to going back further. My site was infected with some bad maleware code. I have been fighting and fighting that. I FINALLY got rid of it. That is when I tried to update the vB software. That is where my update failed (I'm sure I did something wrong) and thus, here we are now.

          I really appreciate your help.

          Comment


          • #6
            Unfortunately if you 'rolled back' but don't know exactly what you did then I'm not sure how this can be fixed. What is the current status right now?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I am not sure what you mean by "status".

              You can go to the site and it comes up. I have no idea if people can register or not, but they can log in. They can open a forum section. They CAN NOT open an actual thread, though. If they try to read a thread, that is when they get that error.

              I did some random clicking.
              • Who's Online- Working
              • Calendar- Working
              • What's New?- NOT WORKING -It gives the same error.
              • Trying to access my profile- NOT WORKING -It gives the same error.

              Comment


              • #8
                Can you try re-downloading the ZIP file from the Members Area and re-upload all files (except install/install.php and includes/config.php.new) making sure you overwrite all files currently on your server.

                Does this resolve the problem?
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - Highlight the correct navigation tab when you are on a custom page
                - "Quick Route" Interface...
                - Allow to use custom icons for individual forums

                Comment


                • #9
                  I am going to try this. Thanks again. I will let you know how it goes.

                  Comment


                  • #10
                    I wrote a good amount of stuff, but I accidentally pressed the back button. Ugh.

                    A recap:
                    • Re-Uploading the 4.1.2 files worked.
                    • I then ran the .../install/upgrade.php, but I went from 4.1.1 to 4.1.1 Um...

                    THANK YOU and how do I upgrade? lol

                    Comment


                    • #11
                      If you've uploaded all 4.1.2 files, it's not possible to upgrade to 4.1.1. If you go back to .../install/upgrade.php, what is the version numbers in the top right corner?
                      Vote for:

                      - *Admin Settable Paid Subscription Reminder Timeframe*
                      -
                      *PM - Add ability to reply to originator only*
                      - Add Admin ability to auto-subscribe users to specific channel(s)
                      - Highlight the correct navigation tab when you are on a custom page
                      - "Quick Route" Interface...
                      - Allow to use custom icons for individual forums

                      Comment


                      • #12
                        EDIT: I fixed it. Thanks!


                        "vBulletin 4.1.1 Upgrade System"
                        Last edited by DISLEX; Fri 4th Mar '11, 4:19pm.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X