Announcement

Collapse
No announcement yet.

Can not get horizontal rule bbcode to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • abdulbasitsaeed
    replied
    Originally posted by Trevor Hannant View Post
    Try this:

    Code:
    <hr style="color:HR;background-color:HR;display:block;"/>
    You need both color and background-color to be the same for cross browser compatibility. Internet Explorer uses color and ignores background-color. Firefox and Opera will ignore color and use background-color, certainly in older versions. The 'display' element is because there is a display:none in the postbit.css to hide it in other areas of the postbit so you need to override this.
    Thank you very much for helping, Trevor. This indeed works. *thumbup*

    Leave a comment:


  • Trevor Hannant
    replied
    Try this:

    Code:
    <hr style="color:HR;background-color:HR;display:block;"/>
    You need both color and background-color to be the same for cross browser compatibility. Internet Explorer uses color and ignores background-color. Firefox and Opera will ignore color and use background-color, certainly in older versions. The 'display' element is because there is a display:none in the postbit.css to hide it in other areas of the postbit so you need to override this.

    Leave a comment:


  • abdulbasitsaeed
    started a topic [Forum] Can not get horizontal rule bbcode to work

    Can not get horizontal rule bbcode to work

    Well, I've tried creating the bbcode in the following fashion:

    Title: Horizontal Line BBCode
    BB Code Tag Name: line
    Replacement: <hr color="{param}" width="100%" size="1" />

    where param is a colour.

    The problem is that the line shows in a post preview, and also on the recent posts widget for the CMS, but it never shows for the actual post.

    Any ideas what I may be doing wrong here? I'm using vB 4.0.6.

Related Topics

Collapse

Working...
X