Announcement

Collapse
No announcement yet.

Permissions problem for non-registered, non-logged in users

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Permissions problem for non-registered, non-logged in users

    Been all through the permissions here but I can't figure out why when you visit our domain, if you're not logged in, you go direct to a register/login page when we would prefer to show our CMS homepage.

    http://www.newenglandbrigade.org/

    Usergroup manager is set to "Can View Forum" for Usergroup ID 1: Unregistered / Not Logged In - what am I missing?

  • #2
    AdminCP > vBulletin CMS > Permissions

    Does the Unregistered/Not Logged In usergroup have access to view the CMS? Also, make sure you edit the home section of your CMS and set the 'Show on Section widget' option to 'Yes'
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Checked and double checked - both are set correctly and that doesn't fix the problem.

      Users are always being directed to a no permission message and being asked to login before they can view the home page.

      Comment


      • #4
        This was the second time I've come here asking for help to resolve this issue. This has been going on for two weeks and I have a website that I need to get fixed. I would appreciate it if someone at vbulletin could give this some attention.

        Comment


        • #5
          You have to set the appropriate CMS permissions here:

          Admin CP -> vBulletin CMS -> Permissions

          Then edit the Front Page and make sure that "Show on Section widget" to Yes

          And finally, in order for non-Admins to see anything in the CMS you have to have at least one published section and one published article.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Already did all that at Trevor's request - it didnt fix the problem.

            Comment


            • #7
              You did all of that? If so, this is caused ny a modification.

              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

              Admin CP -> Plugins & Products -> Manage Products -> Disable

              Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

              Admin CP -> Plugins & Products -> Plugin Manager

              You must do BOTH of those steps in order to disable all non vBulletin Modifications.

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X