Announcement

Collapse
No announcement yet.

Mobile: 'Full Site' doesn't work!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Mobile: 'Full Site' doesn't work!

    Hi,

    I updated to vB 4.1.2 and everything went well. I installed the Mobile Style and it works. "Default style" is my custom style, "Default Style" for "modern and old mobile browsers" is "Mobile", allow users to change styles is set to "yes".

    If you see my forum www.cureconnections.com from a mobile device the mobile style is working well (except that I have 2x Home (I renamed forum to home)), however when you click on "Full Site" it's still showing the mobile style and simply doesn't change to the full site.

    Here on vBulletin I can switch the way I want it, but not on my site. Any ideas what the reason could be? I don't want to announce the mobile style to my members before it's not working as supposed! Thanks a lot!
    sigpic

  • #2
    I thought it could be something in the footer, and tried to change the style ID by hand, but it didn't work.

    Code:
    <li<vb:if condition="$show['forgetpassword']"> class="last"</vb:if>><a href="{vb:raw vboptions.bburl}/?styleid=-9" rel="external">{vb:rawphrase full_site}</a></li>
    <vb:if condition="!$show['forgetpassword']">
    sigpic

    Comment


    • #3
      My guess as to the cause of that would be a modification.

      To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

      Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

      [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

      Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

      Admin CP -> Plugins & Products -> Manage Products -> Disable

      Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

      Admin CP -> Plugins & Products -> Plugin Manager

      You must do BOTH of those steps in order to disable all non vBulletin Modifications.

      Then if you still have this problem, disable any ads you have running. Do you have the same problem?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Thanks Steve. I did all that already, twice. I don't use ads at all. I checked the whole issue on a fresh test installation and here it works fine. So the problem has to be on my end. Damn. I was so much looking forward to the mobile style and now I have an issue and cannot find it.

        Any hint is more than welcome!
        sigpic

        Comment


        • #5
          I see mods on your site. Are you sure you can dupolicate this with the default vB code?

          If so, keep you modifications disabled and fill out a support ticket at:

          http://members.vbulletin.com/members...ontactform.php

          Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I am afraid I will have to fill a ticket...

            I disabled all of the few addons I use and set the vB default style as forum default. It's still the same, actually everything works fine except for the link to "Full Site" on the mobile style. As said this does not happen on a fresh installation of vB 4.1.2 on my server, however it happens on my live site and my usual test forum (both show the same behavior).

            I just wonder which mod could have such an impact even when it's disabled....
            sigpic

            Comment


            • #7
              use this:
              <li<vb:if condition="$show['forgetpassword']"> class="last"</vb:if>><a href="{vb:raw vboptions.bburl}/forum.php?styleid=9" rel="external">{vb:rawphrase full_site}</a></li>
              <vb:if condition="!$show['forgetpassword']">
              instead of the one you tried in ur second post.
              you forgot to add forum.php ..

              and i had the same problem and much more.. welcome to vbulletin :P

              Comment


              • #8
                Thank you very much mate!! That was it! No mod or anything, just a simple addition and change of the code in the footer! Unbelievable....!

                I quickly tested this via iPhone and will activate it on the love site tonight . Thanks again!
                sigpic

                Comment


                • #9
                  For those who are interested: tonetu's hint helped me fix the issue on my test forum. After doing the same change to the footer my live site was still showing this weird behavior. I located the addon that cases the problem and it is vBSEO. I will see over there what can be done.

                  I apologize Steve, you were right as well!
                  sigpic

                  Comment


                  • #10
                    Thanks for the info.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      OK, I fixed it, in case someone should have the same issue I post what I did. I had to add forum.php like tonetu said. On my test forum without vBSEO I could also change the style ID to my default ID and it worked well. On my live site using vBSEO it didn't work, but after I set the ID back to default =-1 it is now working fine.

                      So the code has to be:

                      Code:
                      <a href="{vb:raw vboptions.bburl}/forum.php?styleid=-1" rel="external">
                      Don't ask me why. I am just beginning with the mobile style, so maybe I lack a lot of tricks here...
                      sigpic

                      Comment


                      • #12
                        I also found that if you have the Suite and have the CMS disabled, the Full Site link will not work. I put in a bug report here - Stuck in Mobile View in a regular browser if your CMS is disabled The fix posted above will work to fix this issue.

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools &lt;- awesome site for html/css help

                        Comment


                        • #13
                          I also removed the second "home" code from the gridmenu (sorry, I am at work so I cannot provide the code at the moment). As mentioned before, the gridmenu shows 2x home, using two different icons. I wanted to remove one as I am not using the CMS (at least not at the moment) to have only one leading to the forum home. Removing the code caused the same issue and made the "Full Site" function not work anymore. Using the default and unchanged template made it work again. I don't know what I have to change to make the gridmenu work the way I want to, but to me it seems a disabled CMS is causing too many issues to the mobile style.
                          sigpic

                          Comment


                          • #14
                            Originally posted by ceho View Post
                            OK, I fixed it, in case someone should have the same issue I post what I did. I had to add forum.php like tonetu said. On my test forum without vBSEO I could also change the style ID to my default ID and it worked well. On my live site using vBSEO it didn't work, but after I set the ID back to default =-1 it is now working fine.

                            So the code has to be:

                            Code:
                            <a href="{vb:raw vboptions.bburl}/forum.php?styleid=-1" rel="external">
                            Don't ask me why. I am just beginning with the mobile style, so maybe I lack a lot of tricks here...
                            Thanks for this! Fixed my issue

                            Comment


                            • #15
                              I've just experienced a similiar problem to that which Lynne raised the bug report on. I intalled this product...

                              http://www.vbulletin.org/forum/showt...228507&page=42

                              ...to allow me to add a Tab to the Navbar. It worked fine first time I did it but the product puts a copyright statement, with links to a Spanish site, at the bottom of every page. Following instructions in that thread I snipped out the copyright info and re-installed the product. That's when I got the problem with the 'mobile' style on my entire board. Funnily enough, even though I'm working on 4.1.2 I haven't actually installed the Mobile Style yet. This is a clean install on a test rig and mobile styles are a way down on my list of things to deal with.

                              Anyway, I added the copyright stuff back into the product xml file and re-installed it; and hey presto the thing worked again (I'm no coder so I can't say why any of this happens). In the end I got around the problem by leaving the copyright text there and simply edtiting out all the infuriating links to the spanish website and replaced it with the original coders handle (Elmer). The thing works a treat now but there's obviously some issue in the footer area here. What will happen when I do install the Mobile Style is anyone's guess. So, just in case, can someone advise me where exactly (which file) I need to make this modification listed earlier in this thread...I have a suspicion I might need it soon!
                              Last edited by Old Git; Sat 12 Mar '11, 8:21am. Reason: Typing is difficult with Carpal Tunnel, sigh!

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X