Announcement

Collapse
No announcement yet.

Remove Redirect to /content

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Then remove that. The purpose of the htaccess file is to redirect, which I am saying is the issue.

    Leave a comment:

  • David Karol
    Member

  • David Karol
    replied
    Originally posted by Steve Machol View Post
    And as I stated, there is nothing in vB that would do this. This is from either an htaccess redirect or another modification you installed. Sorry if that was not clear.
    The htaccess I used is what was provided in the do_not_upload folder for the mod_rewrite URLs, which were turned on from the Admin CP.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    And as I stated, there is nothing in vB that would do this. This is from either an htaccess redirect or another modification you installed. Sorry if that was not clear.

    Leave a comment:

  • David Karol
    Member

  • David Karol
    replied
    Originally posted by Steve Machol View Post
    There is no 'content' directory in vB. That was added manually. http://www.soundforums.net/content
    I realize there is no actual 'content' directory, however I never added that on my own anywhere. Even with all addons disabled, "/content" is being added to the URL. That is using only the files provided in the vBulletin 4.0 release.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    There is no 'content' directory in vB. That was added manually. http://www.soundforums.net/content

    Leave a comment:

  • David Karol
    Member

  • David Karol
    replied
    Originally posted by Steve Machol View Post
    That is my point. You specifically did this. That is not a default configuration. You need to undo whatever changes you made to make that happen.
    Steve,

    I didn't do anything special to install the suite to /. I uploaded the files to that directory and ran the installation from there. To move forums to /live, I added a folder called /live, and filled it with the files provided in the "forum" and "rewrite/forum" sections of the do_not_upload folder.

    Originally posted by azzurro View Post
    This occurs when using the mod_rewrites for friendly URLs, I wanted the same thing for my site.

    In Settings -> Content management,
    Point CMS default to index.php set to Yes.

    However, there is a bug in which pagination causes an infinite loop:
    http://tracker.vbulletin.com/browse/VBIV-10876

    I had a workaround using rewrites but the Facebook integration stopped working, so I had to turn off pagination or go back to /content/ for the index.
    That seems to be the same issue I'm having.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Originally posted by David Karol View Post
    Steve,
    That is the directory I installed the suite to.
    That is my point. You specifically did this. That is not a default configuration. You need to undo whatever changes you made to make that happen.

    Leave a comment:


  • azzurro
    replied
    This occurs when using the mod_rewrites for friendly URLs, I wanted the same thing for my site.

    In Settings -> Content management,
    Point CMS default to index.php set to Yes.

    However, there is a bug in which pagination causes an infinite loop:
    http://tracker.vbulletin.com/browse/VBIV-10876

    I had a workaround using rewrites but the Facebook integration stopped working, so I had to turn off pagination or go back to /content/ for the index.

    Leave a comment:

  • David Karol
    Member

  • David Karol
    replied
    Steve,

    That is the directory I installed the suite to. I just have the "forum component URL" set to live. Even if I try setting the control to show up in a subdirectory, I still get "content/" in the address bar before any of the pages.

    Click image for larger version

Name:	Screen shot 2011-02-13 at 11.33.20 PM.png
Views:	1
Size:	16.0 KB
ID:	3681406

    Wherever the CMS is located, "content" is added after it's directory.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Yes, I know. You need to follow the instructions I provided to have the CMS show in a different directory.

    Leave a comment:

  • David Karol
    Member

  • David Karol
    replied
    Originally posted by Steve Machol View Post
    That is because of a modification you made since your forums are installed here: http://www.soundforums.net/live/forum.php

    Try these instructions:

    http://www.vbulletin.com/docs/html/m...insubdirectory
    Steve,

    The forums are properly working in that directory. Would I need to upload the contents of the cms folder in do_not_upload to the root directory? Would that .htaccess need to go there as well?

    Thanks,

    David Karol

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    That is because of a modification you made since your forums are installed here: http://www.soundforums.net/live/forum.php

    Try these instructions:

    http://www.vbulletin.com/docs/html/m...insubdirectory

    Leave a comment:

  • David Karol
    Member

  • David Karol
    started a topic [CMS] Remove Redirect to /content

    Remove Redirect to /content

    On our homepage (http://www.site.net), the address bar shows

    http://www.site.net/content

    Is there a way to make the CMS show up in the main directory, without "/content" being in front of the pages?

    I just installed a wiki to http://www.site.net/wiki, however, I can't access that directory from the web browser, it also redirects to /content. The .htaccess I am using is from the provided do_not_upload over, as we switched to mod_rewrite URLs for SEO.

    Thanks
    David Karol
    Member
    Last edited by David Karol; Wed 15 Jan '20, 2:20am.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X