Announcement

Collapse
No announcement yet.

Remove Redirect to /content

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Steve Machol View Post
    Which pages?
    Everything.

    Comment


    • #17
      You don't have vBSEO installed do you?

      vBSEO will change the CMS to /content/

      Comment


      • #18
        Originally posted by Dirt Bike Addict View Post
        You don't have vBSEO installed do you?

        vBSEO will change the CMS to /content/
        Nope, it's being done with the .htaccess file provided with vBulletin.

        Comment


        • #19
          Having the same issue. Did anyone find a solution?

          Comment


          • #20
            You will need to edit your rewrite rules to how you wish them.
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - "Quick Route" Interface...

            Comment


            • #21
              Originally posted by Trevor Hannant View Post
              You will need to edit your rewrite rules to how you wish them.
              Trevor,

              It seems that there are a lot of people with the issue.

              http://tracker.vbulletin.com/browse/...s:all-tabpanel

              Would you be able to write a tutorial on how to do so?

              Comment


              • #22
                Hi all,
                I believe that there is an internal redirection.
                You won't be able to remove the 'content' string of the URL, unless you put hands into vBulletin core classes.
                Pitty!
                I've been trying to achieve the same for 3 hours, with no luck!

                Cheers!

                Comment


                • #23
                  Reading this thread really frustrated me. This is a problem with vBulletin, and the customer support is trying to blame the end user.
                  The reason it is doing this is because the default script is 'content.php'. When using friendly URLs, this becomes just 'content/'.
                  So the default path becomes site.com/content/

                  Here is a hack to fix this (imo) bug:
                  https://www.vbulletin.com/forum/show...ing-to-content

                  The final plugin (@ init_startup) is:
                  PHP Code:
                  if ($_SERVER['REQUEST_URI'] == '/')
                  {
                      
                  $vbulletin->options['friendlyurl_canonical'] = 0;
                  }  
                  if (
                  $_SERVER['REQUEST_URI'] == '/content/')
                  {
                      
                  exec_header_redirect('/'301);

                  I have been using it for months now and it has worked perfectly.

                  http://filesharingtalk.com

                  Comment


                  • #24
                    I just found the proper solution, forget about that plugin I've now disabled it and got what I want.
                    In admincp -> settings -> options -> content management:
                    Set "Point CMS default to index.php" to "yes"
                    Set "Site Tab URL" to "" (blank).

                    http://filesharingtalk.com

                    Comment


                    • #25
                      Originally posted by rossco_2005 View Post
                      I just found the proper solution, forget about that plugin I've now disabled it and got what I want.
                      In admincp -> settings -> options -> content management:
                      Set "Point CMS default to index.php" to "yes"
                      Set "Site Tab URL" to "" (blank).
                      Do you run into the following bug when paginating?

                      http://tracker.vbulletin.com/browse/VBIV-10876

                      Comment


                      • #26
                        Originally posted by azzurro View Post
                        Do you run into the following bug when paginating?

                        http://tracker.vbulletin.com/browse/VBIV-10876
                        Yes same issue, I will go back to using my hack.

                        http://filesharingtalk.com

                        Comment


                        • #27
                          This is very old but relevant. How is this done now with 4.2?

                          Comment


                          • #28
                            Same Problem with 4.2.1; I want to simply rename URL/content/ to URL/articles/ (all installed in root)
                            I added this to htaccess to no avail, must be internal??- RewriteRule ^articles/.* content.php [QSA]
                            Last edited by GoneBushX; Fri 13 Sep '13, 11:32pm.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X