Announcement

Collapse
No announcement yet.

Remove Redirect to /content

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Remove Redirect to /content

    On our homepage (http://www.site.net), the address bar shows

    http://www.site.net/content

    Is there a way to make the CMS show up in the main directory, without "/content" being in front of the pages?

    I just installed a wiki to http://www.site.net/wiki, however, I can't access that directory from the web browser, it also redirects to /content. The .htaccess I am using is from the provided do_not_upload over, as we switched to mod_rewrite URLs for SEO.

    Thanks
    Last edited by David Karol; Wed 15 Jan '20, 1:20am.

  • #2
    That is because of a modification you made since your forums are installed here: http://www.soundforums.net/live/forum.php

    Try these instructions:

    http://www.vbulletin.com/docs/html/m...insubdirectory
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      That is because of a modification you made since your forums are installed here: http://www.soundforums.net/live/forum.php

      Try these instructions:

      http://www.vbulletin.com/docs/html/m...insubdirectory
      Steve,

      The forums are properly working in that directory. Would I need to upload the contents of the cms folder in do_not_upload to the root directory? Would that .htaccess need to go there as well?

      Thanks,

      David Karol

      Comment


      • #4
        Yes, I know. You need to follow the instructions I provided to have the CMS show in a different directory.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Steve,

          That is the directory I installed the suite to. I just have the "forum component URL" set to live. Even if I try setting the control to show up in a subdirectory, I still get "content/" in the address bar before any of the pages.

          Click image for larger version

Name:	Screen shot 2011-02-13 at 11.33.20 PM.png
Views:	1
Size:	16.0 KB
ID:	3681406

          Wherever the CMS is located, "content" is added after it's directory.

          Comment


          • #6
            This occurs when using the mod_rewrites for friendly URLs, I wanted the same thing for my site.

            In Settings -> Content management,
            Point CMS default to index.php set to Yes.

            However, there is a bug in which pagination causes an infinite loop:
            http://tracker.vbulletin.com/browse/VBIV-10876

            I had a workaround using rewrites but the Facebook integration stopped working, so I had to turn off pagination or go back to /content/ for the index.

            Comment


            • #7
              Originally posted by David Karol View Post
              Steve,
              That is the directory I installed the suite to.
              That is my point. You specifically did this. That is not a default configuration. You need to undo whatever changes you made to make that happen.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol View Post
                That is my point. You specifically did this. That is not a default configuration. You need to undo whatever changes you made to make that happen.
                Steve,

                I didn't do anything special to install the suite to /. I uploaded the files to that directory and ran the installation from there. To move forums to /live, I added a folder called /live, and filled it with the files provided in the "forum" and "rewrite/forum" sections of the do_not_upload folder.

                Originally posted by azzurro View Post
                This occurs when using the mod_rewrites for friendly URLs, I wanted the same thing for my site.

                In Settings -> Content management,
                Point CMS default to index.php set to Yes.

                However, there is a bug in which pagination causes an infinite loop:
                http://tracker.vbulletin.com/browse/VBIV-10876

                I had a workaround using rewrites but the Facebook integration stopped working, so I had to turn off pagination or go back to /content/ for the index.
                That seems to be the same issue I'm having.

                Comment


                • #9
                  There is no 'content' directory in vB. That was added manually. http://www.soundforums.net/content
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol View Post
                    There is no 'content' directory in vB. That was added manually. http://www.soundforums.net/content
                    I realize there is no actual 'content' directory, however I never added that on my own anywhere. Even with all addons disabled, "/content" is being added to the URL. That is using only the files provided in the vBulletin 4.0 release.

                    Comment


                    • #11
                      And as I stated, there is nothing in vB that would do this. This is from either an htaccess redirect or another modification you installed. Sorry if that was not clear.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Originally posted by Steve Machol View Post
                        And as I stated, there is nothing in vB that would do this. This is from either an htaccess redirect or another modification you installed. Sorry if that was not clear.
                        The htaccess I used is what was provided in the do_not_upload folder for the mod_rewrite URLs, which were turned on from the Admin CP.

                        Comment


                        • #13
                          Then remove that. The purpose of the htaccess file is to redirect, which I am saying is the issue.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by Steve Machol View Post
                            Then remove that. The purpose of the htaccess file is to redirect, which I am saying is the issue.
                            When mod_rewrite SEO URLs are turned on, and I remove the htaccess file, I can't see the pages though.

                            Comment


                            • #15
                              Which pages?
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X