Announcement

Collapse
No announcement yet.

Cookie troubles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Cookie troubles

    I'm working on a board for www.newenglandbrigade.org - and we're having all sorts of problems with users staying logged in.

    When you go to the board, instead of seeing the homepage you're taken to a login screen. Logging in there doesn't hold your login, but clicking on the forum you'll find yourself suddenly logged in.

    I thought it might be a problem with the htaccess file so I put a redirect in there for non-www users. That doesn't seem to help.

    Session timeout is at 900 in vbulletin options
    Path to cookies is set as "/" .
    Cookie domain is set to blank.

    I'm not sure what else to do - users can't stay logged in.

  • #2
    Do you have anything else in your .htaccess file?

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Originally posted by Lynne View Post
      Do you have anything else in your .htaccess file?
      Code:
      # -FrontPage-
      
      IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
      
      <Limit GET POST>
      order deny,allow
      deny from all
      allow from all
      </Limit>
      <Limit PUT DELETE>
      order deny,allow
      deny from all
      </Limit>
      AuthName newenglandbrigade.org
      AuthUserFile /home/newengla/public_html/_vti_pvt/service.pwd
      AuthGroupFile /home/newengla/public_html/_vti_pvt/service.grp
      
      # To redirect all users to access the site WITH the www. prefix,
      # (http://example.com/... will be redirected to http://www.example.com/...)
      # adapt and uncomment the following:
      
      RewriteEngine On
      RewriteCond %{HTTP_HOST} !^www\.newenglandbrigade\.org$ [NC]
      RewriteRule ^(.*)$ http://www.newenglandbrigade.org/$1 [L,R=301]

      Comment


      • #4
        I don't see anything obviously wrong with that.

        Try setting your cookie domain to ".yoursite.com" (note the period at the beginning, but no quotes). See if that helps out.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools &lt;- awesome site for html/css help

        Comment


        • #5
          Originally posted by Lynne View Post
          I don't see anything obviously wrong with that.

          Try setting your cookie domain to ".yoursite.com" (note the period at the beginning, but no quotes). See if that helps out.
          I adjusted that setting - but I had already tried that once before so I'm not confident it's going to fix anything. Any other suggestions?

          Comment


          • #6
            Make sure users click the Remember Me when they login.

            What do you have your Session Timeout set to?

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools &lt;- awesome site for html/css help

            Comment


            • #7
              Originally posted by Smelly_Fed View Post
              Session timeout is at 900 in vbulletin options
              I'm not sure what else to do - users can't stay logged in.
              Currently set at default 900 - whats the maximum range?

              Comment


              • #8
                900 is 15 minutes which is the default and should be fine.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools &lt;- awesome site for html/css help

                Comment


                • #9
                  Im having the same problem..

                  my htaccess says this

                  # -FrontPage-
                  Options None
                  <Limit GET POST>
                  order deny,allow
                  deny from all
                  allow from all
                  require group authors administrators
                  </Limit>
                  <Limit PUT DELETE>
                  order deny,allow
                  deny from all
                  </Limit>
                  AuthType Basic
                  AuthName www.offtopicz.com
                  AuthUserFile /home/vshayes/public_html/_vti_pvt/service.pwd
                  AuthGroupFile /home/vshayes/public_html/_vti_pvt/service.grp
                  Does anyone know what mine should say to fix the problem? IM having the same problem

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X