Announcement

Collapse
No announcement yet.

Facebook Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Facebook Integration

    The integration of Facebook with VB is confusing, mostly on the FaceBook end.

    My forum is at www.NHTourGuide.com/forums

    Can anyone help me with these questions...

    What should be in the "Canvas URL?"

    Is the "Secure Canvas URL" required?

    What goes in the "Post-Authorize Callback URL?"

    What goes in the "Post-Authorize Redirect URL?"

    Thanks!
    Last edited by NHTourGuide; Wed 9 Feb '11, 6:01am.
    NHTourGuide.com

  • #2
    All the tutorials, even on YouTube are for the older Facebook format. Facebook changed the developer section.

    anyone have detailed instructions on how to complete the Facebook Connect feature on the Facebook end?
    NHTourGuide.com

    Comment


    • #3
      Am I posting in the wrong place? Im trying to get help with my VBulletin forum and I was told that I had to post here for support but am not getting any replies...

      What am I doing wrong?
      NHTourGuide.com

      Comment


      • #4
        NH

        I followed the instructions found here:
        http://www.vbulletin.com/forum/showt...-Common-Issues

        and connected my forum with vbulletin in 5 minutes.

        Comment


        • #5
          Originally posted by chapsrulez View Post
          NH

          I followed the instructions found here:
          http://www.vbulletin.com/forum/showt...-Common-Issues

          and connected my forum with vbulletin in 5 minutes.
          Thanks, but from what I have found, FB changed the developer section and all the instructions given in that post by VB are outdated. Even the url for the example (www.nocostinstall.com/) is now some PTSD website for people with post-traumatic stress disorder.

          From what I can see, VB offers nothing for instructions on this new set up.

          Thanks for your help though!!
          NHTourGuide.com

          Comment


          • #6
            NH

            I followed that how-to last week
            im new to vb4

            Comment


            • #7
              The link to www.nocostinstall.com is an *example* url
              Enter your site URL in the "Connect URL" field. Example here is: http://www.nocostinstall.com/ (Take notice off trailing slash)
              The instructions in the manual are valid - http://www.vbulletin.com/docs/html/facebook_enable

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools <- awesome site for html/css help

              Comment


              • #8
                Originally posted by chapsrulez View Post
                NH

                I followed that how-to last week
                im new to vb4
                I must be doing something wrong, just not sure where I went wrong yet...
                Originally posted by Lynne View Post
                The link to www.nocostinstall.com is an *example* url


                The instructions in the manual are valid - http://www.vbulletin.com/docs/html/facebook_enable
                It doesn't look that simple on my end.

                When I try to enter the url on the FaceBook screen the way it is in my Admin CP (eithout trailing slash), it gives me an error; Screenshot of error is here: http://www.nhtourguide.com/images/fo...es/Capture.JPG

                On my forum, you are able to "like" a post but from what I can see thats all you can do. There is no "Connect" button at the top.

                If you go to register it has a Facebook section at the top of the registration but it's blank.
                NHTourGuide.com

                Comment


                • #9
                  Then try adding the trailing slash anyway.

                  Please don't PM or VM me for support - I only help out in the threads.
                  vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                  Want help modifying your vbulletin forum? Head on over to vbulletin.org
                  If I post CSS and you don't know where it goes, throw it into the additional.css template.

                  W3Schools <- awesome site for html/css help

                  Comment


                  • #10
                    Originally posted by chapsrulez View Post
                    NH

                    I followed that how-to last week
                    im new to vb4
                    Originally posted by Lynne View Post
                    The link to www.nocostinstall.com is an *example* url


                    The instructions in the manual are valid - http://www.vbulletin.com/docs/html/facebook_enable
                    Originally posted by Lynne View Post
                    Then try adding the trailing slash anyway.
                    I added the trailing slash as FaceBook required but still nothing.

                    What about the "FaceBook Integration" settings? Here is a screenshot of what is there now: http://nhtourguide.com/images/forum_images/Capture2.JPG
                    NHTourGuide.com

                    Comment


                    • #11
                      Screenshot of "Advanced" settings: http://nhtourguide.com/images/forum_images/Capture3.JPG
                      NHTourGuide.com

                      Comment


                      • #12
                        You should not be entering anything where it says Canvas URL or any other URLs on any page - the ONLY thing you should enter is the Forum URL on the Web Site page.

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools <- awesome site for html/css help

                        Comment


                        • #13
                          Originally posted by Lynne View Post
                          You should not be entering anything where it says Canvas URL or any other URLs on any page - the ONLY thing you should enter is the Forum URL on the Web Site page.
                          ok, I deleted the FB app and started over with a new app. I only entered the website url of the forum http://nhtourguide.com/forums/ (with the trailing slash as it wont let me take it out).

                          The problem remains. I have the "like" buttons but no "connect" button at the top and no information during forum registration under "The Facebook Platform."
                          NHTourGuide.com

                          Comment


                          • #14
                            And have you turned it on in the options? AdminCP > Settings > Options > facebook options > enable facebook platform ? And have you tried this on a totally default style?

                            Please don't PM or VM me for support - I only help out in the threads.
                            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                            Want help modifying your vbulletin forum? Head on over to vbulletin.org
                            If I post CSS and you don't know where it goes, throw it into the additional.css template.

                            W3Schools <- awesome site for html/css help

                            Comment


                            • #15
                              Originally posted by Lynne View Post
                              And have you turned it on in the options? AdminCP > Settings > Options > facebook options > enable facebook platform ? And have you tried this on a totally default style?
                              I have turned it on in the options. Have not tried on a default style, not sure what that means.

                              I did just notice that it was asking for me to revert the template and I did that and now the Facebook all looks like its working, just have to add the style changes back in.

                              I didnt realize the revert on styles would affect the function of the forum... strange.

                              Thanks for your help!
                              NHTourGuide.com

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X