Announcement

Collapse
No announcement yet.

AdminCP problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] AdminCP problem

    I have searched and searched this forum and I have not been able to find anything on this issue. In my admincp the link at the top right that says Forum Home Page is for whatever reason linking to http://testsite.pcandgforum.com/admincp/forum.php I have went through every setting that I can find that would have anything to do with this changed some things around to see if I can get any different result, but still no luck. I reverted the templates, copied over a fresh index.php in the admincp directory, and I've even reinstalled vb4.1.1 and still get the same result. I'm not sure if it's a bug or just me, maybe something I did wrong on the install? Any help with this would be apreciated!

  • #2
    I'm a little confused by your post... but...

    Originally posted by cdement
    In my admincp the link at the top right that says Forum Home .....
    What do you have set for: AdminCP -> Settings -> Options -> Site Name / URL / Contact Details -> Forum URL?
    To be updated...

    Comment


    • #3
      http://testsite.pcandgforum.com

      but I have tried it as http://testsite.pcandgforum.com/index.php and http://testsite.pcandgforum.com/forum.php and I get the same results regardless

      Comment


      • #4
        Ok. In re-reading your original message, I just want to be clear on one thing:

        You said that with either link mentioned above, would give the same result. Are you saying that it's linking to your URL with the /admincp/index.php part? (adding the AdminCP part in?)
        To be updated...

        Comment


        • #5
          Ok so what the deal is this:

          Example from my live site is the Forum Home Page link is http://pcandgforum.com/forum.php which is the correct link

          Now with the test site where I'm testing 4.1.1 before I go live with it the correct link should be http://testsite.pcandgforum.com/forum.php but it is putting in the link as http://testsite.pcandgforum.com/admincp/forum.php the thing I am not understanding is why it is putting the /admincp/forum.php instead of just /forum.php like it should be. Obviously forum.php does not exist in the admincp directory, so I've never had this happen I set up everything the same way as my live site but it just has the subdomanin of testsite. This didn't happen with 4.1.0 but now all of a sudden it is happening with 4.1.1??

          Comment


          • #6
            Understood.

            I'm a bit baffled too - although I'm thinking in the back of my mind, there's something simple in the configuration that could cause this.

            Could it have anything to do with how you have the security enabled for that sub-domain? (I see that the test site is password protected...)

            It feels like it may be a forced redirect, but from where would be the question...

            Otherwise, I'm not really sure to be honest. Will think about it a bit...
            To be updated...

            Comment


            • #7
              I never really thought of that, but I would think that if it's the protected directory setup of that subdomain that there would be more issues than just that link not being correct. I will play around with it though to see if I get any other results. I though it could possibly be something in the config.php file but I've went through it a thousand times and everything seems ok in there. I just find it a little odd though that it's just the admincp, although I haven't tried the modcp just yet but I will take a look at it today and see if it has the same issue or not.

              Edit: I took a look at the modcp and same result it creates the link as http://pcandgforum.com/modcp/forum.php seems strange like I'm missing a setting somewhere.

              Edit: It has something to do with this line of code which I'm no php expert, but I gather this is where it creates the link

              Code:
              $forumhomelink = create_full_url(fetch_seo_url('forumhome', array()), true);
              That is straight out of the index.php file in the admincp directory.
              Last edited by cdement; Wed 2nd Feb '11, 8:10am.

              Comment


              • #8
                Still have no figured out this issue yet. Anyone have any ideas what would cause this?

                Comment


                • #9
                  Ok, I have installed a fresh new copy of vbulletin 4.1.1 with a fresh new database and no hacks at all. The forum homepage link in the admincp is now the correct link of how it is supposed to be. When I logout of the admincp and come to this screen

                  Click image for larger version

Name:	Untitled.png
Views:	1
Size:	15.1 KB
ID:	3681347

                  the link that is titled Test Forums is still http://testsite.pcandgforum.com/admincp/forum.php and I have tried and tried to figure this out and I get nothing. Can someone tell me if I have done something wrong or if there is a setting that I goofed up in the install because this is getting quite annoying.

                  Comment


                  • #10
                    Are you using memcached, apc, eacclerator, etc to cache your datastore? Are you using this on your test site?
                    What is your AdminCP > Settings > Options > Site Name / URL / Contact Details > Forum URL set to?
                    Can you link to your phpinfo?

                    Comment


                    • #11
                      No it's the default cache method, everything is default. Yes this is a test site. Forum URL is set to http://testsite.pcandgforum.com and I'm not sure how to link the phpinfo as this is a test site so I have a .htaccess file in place that locks this site down with a password.

                      Comment


                      • #12
                        bump on this! still cannot figure this out. no clue what's causing this or what else to do to make it work correctly.

                        Comment


                        • #13
                          Originally posted by cdement View Post
                          bump on this! still cannot figure this out. no clue what's causing this or what else to do to make it work correctly.
                          Hey - I saw this thread pop up again. Have you filed a support ticket with vBulletin to get some direct assistance?

                          I think someone needs to log-in to your site control and take a look around to try and figure this out. It has to be something set in your site control panel or some other configuration spot. I honestly have no idea myself without looking at the site settings themselves. I've seen some funky configurations, so it wouldn't surprise me. A fresh set of eyes could yield some good results.
                          To be updated...

                          Comment


                          • #15
                            That bug is it. Already applied the fix. Thank you for your help!

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X