Announcement

Collapse
No announcement yet.

Database errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Database errors

    I moved the site (had it done by the new host) and in addition to errors like my CMS page disappearing I am getting many errors such as this;
    Database error in vBulletin 4.1.0:

    Invalid SQL:
    SELECT SQL_CALC_FOUND_ROWS node.nodeid AS itemid **,(node.nodeleft = 1) AS isroot, node.nodeid, node.contenttypeid, node.contentid, node.url, node.parentnode, node.styleid, node.userid,
    * * * * * * * * * * * *node.layoutid, node.publishdate, node.setpublish, node.issection, parent.permissionsfrom as parentpermissions,
    * * * * * * * * * * * *node.showrating,
    * * * * * * * * * * * *node.permissionsfrom, node.publicpreview, node.shownav, node.hidden, node.nosearch , info.description, info.title, info.viewcount, info.creationdate, info.workflowdate,
    * * * * * * * * * * info.workflowstatus, info.workflowcheckedout, info.workflowlevelid, info.associatedthreadid,
    * * * * * * * * * * user.username, sectionorder.displayorder
    * * * * * * * * * *
    * * * * * * * * * *
    * * * * * * * *FROM cms_node AS node
    * * * * * * * *INNER JOIN cms_nodeinfo AS info ON info.nodeid = node.nodeid
    * * * * * * * *LEFT JOIN user AS user ON user.userid = node.userid
    * * * * * * * *LEFT JOIN cms_sectionorder AS sectionorder ON sectionorder.sectionid = node.parentnode
    * * * * * * * *AND sectionorder.nodeid = node.nodeid
    * * * * * * * *LEFT JOIN cms_node AS parent ON parent.nodeid = node.parentnode * *
    * * * * * * * *
    * * * * * * * *WHERE node.new != 1 *AND node.nodeid IN (1) *AND ( (node.permissionsfrom IN ()) OR ( node.permissionsfrom in () AND (node.parentnode IN (1) OR node.nodeid = 1) AND
    * * * * * * * *node.setpublish > 0 AND node.publishdate < 1296584087 ))AND node.new != 1
    * * * * * * * *
    * * * * * * * * *ORDER BY CASE WHEN sectionorder.displayorder > 0 THEN sectionorder.displayorder ELSE 9999999 END ASC,
    * * * * * * * * * * node.publishdate DESC;

    MySQL Error **: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')) OR ( node.permissionsfrom in () AND (node.parentnode IN (1) OR node.nodeid = ' at line 16
    Error Number *: 1064
    Request Date *: Tuesday, February 1st 2011 @ 12:14:47 PM
    Error Date ***: Tuesday, February 1st 2011 @ 12:14:47 PM
    Script *******: http://www.shottalk.com/forum/content.php
    Referrer *****:
    IP Address ***: 88.64.76.226
    Username *****: Unregistered
    Classname ****: vB_Database
    MySQL Version :
    Should I just reinstall the software?
    Shot Talk

  • #2
    Did you censor or modify that query at all?

    Comment


    • #3
      No.
      I copied it using my phone, not sure if that had and effect or not.
      Shot Talk

      Comment


      • #4
        see if this is any better...

        Database error in vBulletin 4.1.0:

        Invalid SQL:
        SELECT SQL_CALC_FOUND_ROWS node.nodeid AS itemid **,(node.nodeleft = 1) AS isroot, node.nodeid, node.contenttypeid, node.contentid, node.url, node.parentnode, node.styleid, node.userid,
        * * * * * * * * * * * *node.layoutid, node.publishdate, node.setpublish, node.issection, parent.permissionsfrom as parentpermissions,
        * * * * * * * * * * * *node.showrating,
        * * * * * * * * * * * *node.permissionsfrom, node.publicpreview, node.shownav, node.hidden, node.nosearch , info.description, info.title, info.viewcount, info.creationdate, info.workflowdate,
        * * * * * * * * * * info.workflowstatus, info.workflowcheckedout, info.workflowlevelid, info.associatedthreadid,
        * * * * * * * * * * user.username, sectionorder.displayorder
        * * * * * * * * * *
        * * * * * * * * * *
        * * * * * * * *FROM cms_node AS node
        * * * * * * * *INNER JOIN cms_nodeinfo AS info ON info.nodeid = node.nodeid
        * * * * * * * *LEFT JOIN user AS user ON user.userid = node.userid
        * * * * * * * *LEFT JOIN cms_sectionorder AS sectionorder ON sectionorder.sectionid = node.parentnode
        * * * * * * * *AND sectionorder.nodeid = node.nodeid
        * * * * * * * *LEFT JOIN cms_node AS parent ON parent.nodeid = node.parentnode * *
        * * * * * * * *
        * * * * * * * *WHERE node.new != 1 *AND node.nodeid IN (1) *AND ( (node.permissionsfrom IN ()) OR ( node.permissionsfrom in () AND (node.parentnode IN (1) OR node.nodeid = 1) AND
        * * * * * * * *node.setpublish > 0 AND node.publishdate < 1296589088 ))AND node.new != 1
        * * * * * * * *
        * * * * * * * * *ORDER BY CASE WHEN sectionorder.displayorder > 0 THEN sectionorder.displayorder ELSE 9999999 END ASC,
        * * * * * * * * * * node.publishdate DESC;

        MySQL Error **: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')) OR ( node.permissionsfrom in () AND (node.parentnode IN (1) OR node.nodeid = ' at line 16
        Error Number *: 1064
        Request Date *: Tuesday, February 1st 2011 @ 01:38:08 PM
        Error Date ***: Tuesday, February 1st 2011 @ 01:38:08 PM
        Script *******: http://www.shottalk.com/forum/content.php
        Referrer *****: http://www.shottalk.com/forum/content.php
        IP Address ***: 80.92.96.121
        Username *****: Unregistered
        Classname ****: vB_Database
        MySQL Version :
        Shot Talk

        Comment


        • #5
          Try cearling the cms cache, rebuild the node info, and clear the cache again.

          Comment


          • #6
            No workee.

            I'm missing loads of stuff, new posts tab displays a blank page for instance.
            I'll try upgrading the software and see if that helps.
            Shot Talk

            Comment


            • #7
              I would suggest getting another backup and re-moving the database over.

              Comment


              • #8
                Exact same issue here - sometimes the error message above, sometimes blank pages.

                What was the fix for this please? Many thanks.
                Mike Warner
                MIGWeb - a Vauxhall Site for Enthusiasts of all Vauxhalls

                Comment


                • #9
                  I installed a software upgrade and that did the trick for me.
                  Shot Talk

                  Comment


                  • #10
                    Was it by any chance an upgrade of php? I've just realised the new server has php 5.1.6, and the minimum required for vBulletin in 5.2.x
                    Mike Warner
                    MIGWeb - a Vauxhall Site for Enthusiasts of all Vauxhalls

                    Comment


                    • #11
                      The new server had the upgraded php on it already so that would be a component.
                      Shot Talk

                      Comment


                      • #12
                        Just upgraded php to 5.2.17 and it works now, but xcache doesn't..... do the problems never end.....

                        Thanks.
                        Mike Warner
                        MIGWeb - a Vauxhall Site for Enthusiasts of all Vauxhalls

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X