Announcement

Collapse
No announcement yet.

Database error when updating usergroups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Database error when updating usergroups

    I'm trying to alter the avatar size setting in each usergroup, but when I click to update I get this database error-

    Database error in vBulletin 4.1.0:

    Invalid SQL:
    UPDATE usergroup SET


    ### UPDATE QUERY GENERATED BY fetch_query_sql() ###
    `title` = 'Administrators',
    `description` = '',
    `usertitle` = 'Administrator',
    `opentag` = '',
    `closetag` = '',
    `passwordexpires` = '0',
    `passwordhistory` = '0',
    `postsforurls` = '',
    `akvbghsfs_akismet_permissions` = '0',
    `forumpermissions` = '16777215',
    `genericpermissions` = '2147483583',
    `attachlimit` = '0',
    `pmquota` = '500',
    `pmpermissions` = '7',
    `pmsendmax` = '50',
    `pmthrottlequantity` = '0',
    `calendarpermissions` = '63',
    `wolpermissions` = '31',
    `adminpermissions` = '3',
    `genericpermissions2` = '1',
    `genericoptions` = '55',
    `profilepicmaxwidth` = '100',
    `profilepicmaxheight` = '100',
    `profilepicmaxsize` = '65535',
    `avatarmaxwidth` = '120',
    `avatarmaxheight` = '120',
    `avatarmaxsize` = '20000',
    `signaturepermissions` = '237567',
    `sigpicmaxwidth` = '550',
    `sigpicmaxheight` = '200',
    `sigpicmaxsize` = '25000',
    `sigmaxrawchars` = '0',
    `sigmaxchars` = '0',
    `sigmaxlines` = '0',
    `sigmaxsizebbcode` = '7',
    `sigmaximages` = '0',
    `albumpermissions` = '255',
    `albumpicmaxwidth` = '600',
    `albumpicmaxheight` = '600',
    `albummaxpics` = '100',
    `albummaxsize` = '0',
    `usercsspermissions` = '191',
    `visitormessagepermissions` = '63',
    `socialgrouppermissions` = '262143',
    `maximumsocialgroups` = '5',
    `groupiconmaxsize` = '65535'
    WHERE usergroupid=6;

    MySQL Error : Unknown column 'postsforurls' in 'field list'
    Error Number : 1054

  • #2
    Looks like you have a old mod installed somewhere.

    The 'postsforurls' field is not a standard vBulletin field.

    You'll need to trace down this mod and either fix it or remove it.

    A quick search turned up this:

    EDIT: Search for this file from a modification, bitfield_restricturls.xml - if you have this file installed somewhere, remove it. Then try again.
    To be updated...

    Comment


    • #3
      How do I search the modifications to find that file?
      I've removed any old mods I had but the problem is still there. Can't see any easy way to search the mods and find which one is using that file.

      Comment


      • #4
        OK, I've searched vbulletin.org and found which mod that belongs to, but I no longer have it installed. If the file could still be lurking somewhere, which folder would it be in?

        Comment


        • #5
          Originally posted by joanne862 View Post
          OK, I've searched vbulletin.org and found which mod that belongs to, but I no longer have it installed. If the file could still be lurking somewhere, which folder would it be in?
          Potentially, your ./includes/xml folder. If you run a file check via the AdminCP, it should turn up as a non-vbulletin file.
          To be updated...

          Comment


          • #6
            Found it in that folder and it's working great now!

            Thank you!!!

            Comment


            • #7
              Originally posted by joanne862 View Post
              Found it in that folder and it's working great now!

              Thank you!!!
              You're welcome, glad it was an easy fix.
              To be updated...

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X