Announcement

Collapse
No announcement yet.

vB 4 Upgrade stuck for several days

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] vB 4 Upgrade stuck for several days

    By upgrade process has been displaying the following for days now..

    Upgrading to 4.1.0
    Status: Processing XML, Step 6 of 6


    How can I fail this process to startiti again, or possibly just go to the next bundle?


    Thanks!

  • #2
    This may be a server time and/or memory limit. To increase your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', -1);
    ini_set("max_execution_time", "2880");

    Then reload that page.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      hmm.. still just hanging...

      When I reload, it gives me the option to begin the upgrade:

      Press the button below to run the Final Upgrade step

      after I click begin, it goes right to step 6/6, and just hangs.

      Edit: Looks like it's working.. went back to 4/6... at 50%

      will keep thread updated.

      Update: Completed!

      Thanks!

      Comment


      • #4
        Glad to hear it.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          FWIW, I too was stuck on processing during the upgrade from 4.0.8 to 4.1.2. The changes advised above did get me past step 3, but it got stuck again at step 4. I agree the lack of details during the upgrade is frustrating. If the upgrade gets stuck, I would think a message should indicate where the timeout occurred and the advised changes.

          I was able to finish the [forum] upgrade via commandline.

          I went back to the browser to see if I could finish the upgrade "normally" and this time the upgrade got stuck at Blog upgrade step 10.
          Back to the commandline I went and re-ran the upgrade.
          Then back to the browser again to see if I could get further along - and this time the upgrade stopped at Step 4 of 6 processing XML.

          So I guess the bottom line is that the commandline upgrade is about as far as I'm gonna get - but it doesn't give me a whole lot of confidence not being able to use the same upgrade process I have used for many versions (browser) no longer works.
          Last edited by conradk; Sun 27th Feb '11, 6:31am.

          Comment


          • #6
            I had this same issue, was stuck on Processing XML, step 3 of 6.

            I made the ini_set changes recommended in post 2 up above and then reloaded, which got me to step 4 of 6, but now it's stuck again.

            The last thing it did was "Template Group: Poll"

            Comment


            • #7
              Refreshing a few times eventually got me through, but left me with a world of errors and a non-functioning board (good thing this was just a test run).

              Here's the error at the end:

              Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: forumhome_loggedinuser in [path]/includes/functions.php on line 4097

              Parse error: syntax error, unexpected T_STRING in /home/moyer921/reddeadredemptionmovie.net/forum.php(653) : eval()'d code(11) : eval()'d code on line 1

              Comment


              • #8
                Please don't hijack others threads. Those are caused by your third party addons still being enabled. Try adding define("DISABLE_HOOKS", true); to your config.php file.

                Comment


                • #9
                  Is there an answer to this problem? The solution in post 2 doesn't work for me. After not finding an answer here, I googled but there are still no answers out there about how to get past the XML portion of the installation. I've tried the installation over 40 times with 2 different customer numbers and fresh, virginal software- no add ons or mods ever installed. They both do the same thing. Does anyone here have any advice?

                  Comment


                  • #10
                    Please start your own thread with all the relevant details. Thank you.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X