Announcement

Collapse
No announcement yet.

Got a packet bigger than 'max_allowed_packet' bytes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Got a packet bigger than 'max_allowed_packet' bytes

    I'm trying to restore my database dump is which is 5.1Gb file and I keep getting the following error..

    ERROR 1153 (08S01) at line 2607660: Got a packet bigger than 'max_allowed_packet' bytes

    I've already adjusted the max_allowed_packet setting in /etc/my.cnf and restarted mySQL.

    Currently it is set to 512MB and I'm still failing. Any suggestions?

    Also is it possible to split the posts table to have like an archive for older information since the forum contains threads/posts for the last 11 years.
    Larry D
    www.newcelica.org

  • #2
    you set the server max packet size, you need to set the client too

    try

    shell> mysql --max_allowed_packet=32M

    then try your restore

    more here:
    http://dev.mysql.com/doc/refman/5.0/...too-large.html

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X