Announcement

Collapse
No announcement yet.

latin accents won't appear correctly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] latin accents won't appear correctly

    Hi,
    yesterday i've upgrated to 4.1.0 PL 2.

    It seems that latin characters with accents won't appear correctly in new posts. For example, instead of é, à etc. it rather shows the code &#233 &#224

    luckily, greek letters do appear right.

    can you tell what's wrong?

    thanks
    Dimitris

  • #2
    Are you using a language pack or the default English? If a language pack, is the character encoding the same as your database?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      I use my greek language pack. The "HTML Character Set" is set to ISO-8859-7. MySQL seems to work with UTF-8 Unicode (utf8). You think, that's the problem?

      btw. i've just tried to execute an SQL query via the Admin-cp and I get "You are not authorized to execute SQL queries". Why not?

      thanx,
      D.

      Comment


      • #4
        Originally posted by dimitrios View Post
        I use my greek language pack. The "HTML Character Set" is set to ISO-8859-7. MySQL seems to work with UTF-8 Unicode (utf8). You think, that's the problem?
        It is probably not good to have different encodings for the language and for the database.

        Originally posted by dimitrios View Post
        btw. i've just tried to execute an SQL query via the Admin-cp and I get "You are not authorized to execute SQL queries". Why not?
        You need to edit your config.php to give yourself permission to do that.

        /Anders
        Anders Pettersson
        Don't send me requests by PM to email you the Swedish language file that I have done. My translation is only available here at vbulletin.com to licensed users.
        If you want updates on when a new version of the Swedish language packs (forum & suite) are available, subscribe to this discussion.
        Don't PM me for support on how to install language files etc. please post in the appropriate forum, that will most likely give you help quicker.

        Comment


        • #5
          thanx, Anders

          Originally posted by Anders P View Post
          It is probably not good to have different encodings for the language and for the database.
          Thus, am I to set a different value to the "HTML Character Set"? What exactly?

          Originally posted by Anders P View Post
          You need to edit your config.php to give yourself permission to do that.
          Ok, I see this. Must be this one, right? -> $config['SpecialUsers']['canrunqueries'] = '';

          Comment


          • #6
            Originally posted by dimitrios View Post
            Thus, am I to set a different value to the "HTML Character Set"? What exactly?
            Well I am not sure if it helps, but the first thing I would do is to make sure I use the same encoding in the language settings as in the database. If your database is utf8 I would change the language setting to that as well, and also make sure that the language file is in utf8 before uploading it. A good text editor can do that.


            Originally posted by dimitrios View Post
            Ok, I see this. Must be this one, right? -> $config['SpecialUsers']['canrunqueries'] = '';
            yes, that would be it.

            /Anders
            Anders Pettersson
            Don't send me requests by PM to email you the Swedish language file that I have done. My translation is only available here at vbulletin.com to licensed users.
            If you want updates on when a new version of the Swedish language packs (forum & suite) are available, subscribe to this discussion.
            Don't PM me for support on how to install language files etc. please post in the appropriate forum, that will most likely give you help quicker.

            Comment


            • #7
              About the encoding. In AdminCP it says it's "ISO-8859-7" but when i download the xml and open it with an editor, in the first line it reads "encoding="ISO-8859-1".

              Further, I've opened the file both in MS-Word and OpenOffice Writer but I don't see any option for changing the encoding.

              About the sql queries. I've edited config.php on the server and set the username:
              $config['SpecialUsers']['canrunqueries'] = 'my-forum-admin-username';

              but i still cannot exectue sql queries via AdminCP. Maybe it should be set likewise before executing the upgrade script?

              help, please!

              Comment


              • #8
                Originally posted by dimitrios View Post
                About the encoding. In AdminCP it says it's "ISO-8859-7" but when i download the xml and open it with an editor, in the first line it reads "encoding="ISO-8859-1".
                I actually think that is a "bug", that it says "ISO-8859-1" in the downloaded language file.
                But if your language is ISO-8859-7 and your database is utf-8 I guess this can cause the problem (note guess, I am not sure).

                Originally posted by dimitrios View Post
                Further, I've opened the file both in MS-Word and OpenOffice Writer but I don't see any option for changing the encoding.
                Try something like Notepad ++ http://notepad-plus-plus.org/

                Originally posted by dimitrios View Post
                About the sql queries. I've edited config.php on the server and set the username:
                $config['SpecialUsers']['canrunqueries'] = 'my-forum-admin-username';

                but i still cannot exectue sql queries via AdminCP. Maybe it should be set likewise before executing the upgrade script?
                You should enter your user-id, not user name. Se some of the other options above in the config.php, which should have a similar setting.

                /Anders
                Anders Pettersson
                Don't send me requests by PM to email you the Swedish language file that I have done. My translation is only available here at vbulletin.com to licensed users.
                If you want updates on when a new version of the Swedish language packs (forum & suite) are available, subscribe to this discussion.
                Don't PM me for support on how to install language files etc. please post in the appropriate forum, that will most likely give you help quicker.

                Comment


                • #9
                  Originally posted by Anders P View Post
                  Try something like Notepad ++ http://notepad-plus-plus.org/
                  looks like a nice app (really does) but i can't seem to find my way with it. Greek letters appear in hex (i.e. xD6), and the app notes the encoding as being utf-8 (in the menu encoding) but ofcourse the second line still reads otherwise (ISO-8859-1).

                  Some other thing. I've download the language pack and when i try to re-upload it, it results this error: "XML Error: Reserved XML Name at Line 2".


                  Originally posted by Anders P View Post
                  You should enter your user-id, not user name. Se some of the other options above in the config.php, which should have a similar setting.
                  indeed, i've put the id there instead and now i can execute sql queries! at least this one thing worked!

                  but what's wrong with the language xml?

                  Comment


                  • #10
                    Originally posted by dimitrios View Post
                    looks like a nice app (really does) but i can't seem to find my way with it. Greek letters appear in hex (i.e. xD6), and the app notes the encoding as being utf-8 (in the menu encoding) but ofcourse the second line still reads otherwise (ISO-8859-1).
                    I am by no means any expert in this, but will try and help you.
                    (I don't use Notepad ++ in English so some of the menu options might be slightly different.)
                    When you open the language file in Notepad ++ you choose "Encoding" (5th option in the menu) and then "Encode in UTF-8". Then you chose "Convert to UTF-8" (also under "Encoding").
                    The first row in the file usually has "ISO-8859-1", but I think this is a bug (my download that is in utf 8 also has this), but you should look at row 7 and there change to utf8.
                    Then the file should be utf8 and you could try and use it.

                    But remember that posts made when you had a different encoding on your forum might still have the same problem, however new posts should work.

                    Since you mentioned that your database is on utf8 the best way should be to change the language file.


                    Originally posted by dimitrios View Post
                    Some other thing. I've download the language pack and when i try to re-upload it, it results this error: "XML Error: Reserved XML Name at Line 2".


                    but what's wrong with the language xml?
                    I have no idea on that.

                    /Anders
                    Anders Pettersson
                    Don't send me requests by PM to email you the Swedish language file that I have done. My translation is only available here at vbulletin.com to licensed users.
                    If you want updates on when a new version of the Swedish language packs (forum & suite) are available, subscribe to this discussion.
                    Don't PM me for support on how to install language files etc. please post in the appropriate forum, that will most likely give you help quicker.

                    Comment


                    • #11
                      Originally posted by dimitrios View Post
                      For example, instead of é, à etc. it rather shows the code &#233 &#224
                      Does this only happen with Quick Reply / Quick Edit? Normally this happens when PHP is not compiled with iconv or mbstring.

                      Does it work if you choose "Disable Probematic AJAX Features" in vB Options -> General Settings -> Disable AJAX Features?


                      Originally posted by dimitrios View Post
                      XML Error: Reserved XML Name at Line 2".
                      As the language name is in the second line, have you tried it with an other name?
                      Code:
                      <language name="ÅëëçíéêÜ" vbversion="4.1.0" product="vbulletin" type="custom">

                      Comment


                      • #12
                        hi,

                        Anders thanks for trying to help. I got an assembly of problems that might be connected and therefore i’ve opened a ticket. Indeed, a couple of things were taken care of but the extended latin characters problem, remains.

                        Michael, sorry, i missed your answer here as i had my attention to the ticket communication.

                        Originally posted by Michael König View Post
                        Does it work if you choose "Disable Probematic AJAX Features" in vB Options -> General Settings -> Disable AJAX Features?
                        i've disabled the problematic AJAX features like you suggested but the problem remains. Characters like é and à won't appear. Should i change this setting back to "enabled"?

                        Originally posted by Michael König View Post
                        Does this only happen with Quick Reply / Quick Edit? Normally this happens when PHP is not compiled with iconv or mbstring.
                        it happens when using advanced editing, too, and not only when quick-replying. I’ve created a new thread with a couple of replies, using the editor, and again my latin extended characters turn to: &#233; &#224; &#251; &#251; &#241; &#224;

                        older posts are affected, too. (what a disaster! )

                        luckily, other alphabets, like cyrillic, seem to appear correctly.

                        Trevor suggested that maybe i should set the UTF-8 value 'on' in the config.php.

                        likewise, i’ve un-commented the line ( $config['Mysqli']['charset'] = 'utf8'; ) in config.php and then the most peculiar thing happened!!! Al of the sudden, I couldn’t use the forum and I was getting the following message with every click:

                        Code:
                        You have been banned for the following reason:
                        No reason was specified.
                        
                        Date the ban will be lifted:
                        when I put the comment slashes back in config.php i could, once again, use the forum. This seems very bad, too.

                        further:
                        i get this, constantly:

                        Code:
                        Άγνωστη τοποθεσία
                        route:content%2F12-25CC-25E1-25E3-25E9-25EA-25DD-25F2-25C1-25F0-25E1-25F1-25E9-25E8-25EC-25DE-25F3-25E5-25E9-25F2-%28-25F3-25F4-25EF-25ED-25CC-25F0-25FC-25F1-25F7-25E5-25F2-25F3-25F4-25EF-25ED-25B8-25F3-25F3-25E5-25EA-25E1-25E9-25E1-25EB-25EB-25EF-25FD%29
                        ( Άγνωστη τοποθεσία = unknown location )

                        Once, it appeared twice simultaneously, from different ips! Next to this very characteristic one, it’s not unusual to notice some user getting some other "unknown location". It is quite disturbing for it suggests that some visitors cannot work with the forum properly.

                        Originally posted by Michael König View Post
                        As the language name is in the second line, have you tried it with an other name?
                        Code:
                        <language name="ÅëëçíéêÜ" vbversion="4.1.0" product="vbulletin" type="custom">
                        There must be something wrong with the encoding! the language name is "Ελληνικά" (Greek) but when i download it, it turns to this, which is apparently the result of mis-encoding it.

                        Comment


                        • #13
                          Originally posted by dimitrios View Post
                          hi,

                          Anders thanks for trying to help. I got an assembly of problems that might be connected and therefore i’ve opened a ticket. Indeed, a couple of things were taken care of but the extended latin characters problem, remains.

                          Michael, sorry, i missed your answer here as i had my attention to the ticket communication.



                          i've disabled the problematic AJAX features like you suggested but the problem remains. Characters like é and à won't appear. Should i change this setting back to "enabled"?



                          it happens when using advanced editing, too, and not only when quick-replying. I’ve created a new thread with a couple of replies, using the editor, and again my latin extended characters turn to: &#233; &#224; &#251; &#251; &#241; &#224;

                          older posts are affected, too. (what a disaster! )

                          luckily, other alphabets, like cyrillic, seem to appear correctly.

                          Trevor suggested that maybe i should set the UTF-8 value 'on' in the config.php.

                          likewise, i’ve un-commented the line ( $config['Mysqli']['charset'] = 'utf8'; ) in config.php and then the most peculiar thing happened!!! Al of the sudden, I couldn’t use the forum and I was getting the following message with every click:

                          Code:
                          You have been banned for the following reason:
                          No reason was specified.
                          
                          Date the ban will be lifted:
                          when I put the comment slashes back in config.php i could, once again, use the forum. This seems very bad, too.

                          further:
                          i get this, constantly:

                          Code:
                          Άγνωστη τοποθεσία
                          route:content%2F12-25CC-25E1-25E3-25E9-25EA-25DD-25F2-25C1-25F0-25E1-25F1-25E9-25E8-25EC-25DE-25F3-25E5-25E9-25F2-%28-25F3-25F4-25EF-25ED-25CC-25F0-25FC-25F1-25F7-25E5-25F2-25F3-25F4-25EF-25ED-25B8-25F3-25F3-25E5-25EA-25E1-25E9-25E1-25EB-25EB-25EF-25FD%29
                          ( Άγνωστη τοποθεσία = unknown location )

                          Once, it appeared twice simultaneously, from different ips! Next to this very characteristic one, it’s not unusual to notice some user getting some other "unknown location". It is quite disturbing for it suggests that some visitors cannot work with the forum properly.



                          There must be something wrong with the encoding! the language name is "Ελληνικά" (Greek) but when i download it, it turns to this, which is apparently the result of mis-encoding it.


                          i have same problem ..
                          what did you do ?
                          i'm working on.
                          what is the problem.
                          how can i fix it

                          Comment


                          • #14
                            Originally posted by Michael König View Post
                            Does this only happen with Quick Reply / Quick Edit? Normally this happens when PHP is not compiled with iconv or mbstring.

                            Does it work if you choose "Disable Probematic AJAX Features" in vB Options -> General Settings -> Disable AJAX Features?


                            As the language name is in the second line, have you tried it with an other name?
                            Code:
                            <language name="ÅëëçíéêÜ" vbversion="4.1.0" product="vbulletin" type="custom">


                            really i have same problem.
                            how can i fix asscii problem..
                            i have ascii code problem quick edit quick reply..
                            please help me .

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X