Announcement

Collapse
No announcement yet.

Database Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Database Error

    I am getting This Error too much

    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections
    /home/----/public_html/includes/class_core.php on line 313

  • #2
    What kind of plug-ins do you have installed?

    Comment


    • #3
      The server has maxed out the number of MySQL connections it allows. This is a server-wide limit, not just your forums. Unless you have root access to the server all you can do is ask your host to raise the maximum number of connections they allow.

      Here is more info on that error:

      http://dev.mysql.com/doc/refman/5.0/...nnections.html
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by Steve Machol View Post
        The server has maxed out the number of MySQL connections it allows. This is a server-wide limit, not just your forums. Unless you have root access to the server all you can do is ask your host to raise the maximum number of connections they allow.

        Here is more info on that error:

        http://dev.mysql.com/doc/refman/5.0/...nnections.html
        yeah i am on hostgator they said thy allow 25 connctions to mysql

        Comment


        • #5
          That is the problem then. You should consider a new hosting plan or host.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I am getting this same error and got the same message from Hostgator. They mention this:

            Hello,

            Everything looks to be working correctly at this time. There is a limit of 25 user connections to MySQL. If you script is making more than 25 separate connections, you will see this error on your webpage. We do have a workaround for vBulletin as it is notorious for causing issues such as this on our shared/reseller servers. You can find the fix here:

            http://support.hostgator.com/article.../vbulletin-fix

            Please let us know if you have any questions or if there is anything else we can do to assist you.
            I've asked for more options... ggrrrrrrr

            Comment


            • #7
              There is nothing wrong with vBulletin in the case of connections. Your webhost just has a small number of connections @ one time.

              Comment


              • #8
                I'm having the same issue with Host Gator. Is the 25 connection limit referring to the number of sites on the shared host connecting at once, or does it refer to the number of users logged in to my site? I rarely have over 10 people on at once, including guests.

                Is this something else completely?

                Thanks,
                Alan

                Comment


                • #9
                  You should ask your host, but I suspect that is the maximum number of MySQL connections for your account.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks for the response. I found this while doing my research http://forums.hostgator.com/max-user...ips-t4388.html

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X