Announcement

Collapse
No announcement yet.

Advanced Friendly URLs Not Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Advanced Friendly URLs Not Working

    I'm in the process of migrating my site from one provider/host/server to another. I've got all the code on the new server and have a temporary URL to see the site (below) but notice that anytime I attempt to access a URL that has a friendly parameter on it, I get a 404 error. I don't see if there is a specific PHP.ini setting or Apache setting that I need to inquire about. Does anyone have any thoughts here?

    I'm not using the MOD rewrite option - only the Advanced Friendly URL one.

    http://jazzfanz.com.previewdns.com/forum.php

    Thanks in advance!

  • #2
    I'm getting this database error on that URL:

    Code:
    <!--
    Database error in vBulletin 4.0.8:
    
    Invalid SQL:
    
                    INSERT IGNORE INTO forum_session
                        (sessionhash, userid, host, idhash, lastactivity, location, styleid, languageid, loggedin, inforum, inthread, incalendar, badlocation, useragent, bypass, profileupdate, apiclientid, apiaccesstoken)
                    VALUES
                        ('970a7d7e7c4aef8ff4cc3e551a12c6ad', 0, '208.109.80.101', '33d8f35be5a42021cd91dca6fc993fc8', 1292500507, '/forum.php', 0, 0, 0, 0, 0, 0, 0, 'Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)', 0, 0, 0, '');
    
    MySQL Error   : Unknown column 'apiclientid' in 'field list'
    Error Number  : 1054
    Request Date  : Thursday, December 16th 2010 @ 04:55:07 AM
    Error Date    : Thursday, December 16th 2010 @ 04:55:08 AM
    Script        : http://jazzfanz.com.previewdns.com/forum.php
    Referrer      : http://www.vbulletin.com/forum/showthread.php?369060-Advanced-Friendly-URLs-Not-Working
    IP Address    : 208.109.80.101
    Username      : Unregistered
    Classname     : vB_Database
    MySQL Version : 
    -->
    Try re-running the upgrade script to resolve that.
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Resolved the upgrade issue. Still have my friendly URL problem though.

      Comment


      • #4
        Can you re-enable that setting so we can see it please
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          Well, the site is kind of live now and I'd have to take it offline or brake it. Essentially it was a 404 error on anything that would normally carry a querystring.

          Is there another way to test this without changing the setting on my live site? I can setup another database if that's necessary.

          Comment


          • #6
            It is likely or possible that your webhost won't support some of the friendly URL settings/.

            Comment


            • #7
              they aren't going to work properly on the preview site because you'll have different things for forum address url etc in admincp

              Comment


              • #8
                Well my DNS propped last night and I immediately checked and it was still an issue. That's why I switched it to the other setting that's live now. The entire site is live on JazzFanz.com.

                I'm happy to test it out again with Support or anyone real-time.

                I guess if it is my hosting provider (I have a pretty big named one), then I'd like to know what settings those are.

                Thanks again!

                Comment


                • #9
                  Code:
                  http://jazzfanz.com/showthread.php?3481-Okur-to-make-his-return-tonight-in-New-Orleans


                  • Basic Friendly URLs:
                    showthread.php?1234-Thread-Title
                  • Advanced Friendly URLs:
                    showthread.php/1234-Thread-Title

                  so the difference is ? versus / wow didn't realise that was it!
                  Last edited by punchbowl; Fri 17 Dec '10, 1:58pm.

                  Comment


                  • #10
                    Correct. I chose the Advanced option originally because my understanding was that it was more "search engine friendly". Issue with changing it now back to Basic is externally linked URLs won't work anymore.

                    Comment


                    • #11
                      so are they set to advanced now? Just not showing?

                      I've actually only ever used standard,basic, mod rewrite - just tested advanced and get a 404 error! So I'm no help. Have you tried a support ticket? http://members.vbulletin.com/ They'll hook you up.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X